summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-06-25 10:03:25 +0100
committerCharles Bos2015-06-25 10:03:25 +0100
commit51e6438b036e978411c068532ff625a075d4a129 (patch)
treec4e2d1df27503765e0ed40ab3ab5c55d0e8a2b07
parent97baaf9b6d26548ff653fe82edc3486f232baecb (diff)
downloadaur-51e6438b036e978411c068532ff625a075d4a129.tar.gz
add patch for non-disk mounts as requested in comments
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--mounts.patch12
3 files changed, 30 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7ea103c2b6f..6e7b27666be6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by makepkg 4.2.1
-# Fri Jun 5 07:16:00 UTC 2015
pkgbase = xfce4-places-plugin
pkgdesc = Places menu plugin for the Xfce panel
pkgver = 1.7.0
- pkgrel = 2
+ pkgrel = 3
url = http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
arch = i686
arch = x86_64
@@ -12,7 +10,9 @@ pkgbase = xfce4-places-plugin
depends = libnotify
depends = xfce4-panel
source = http://archive.xfce.org/src/panel-plugins/xfce4-places-plugin/1.7/xfce4-places-plugin-1.7.0.tar.bz2
+ source = mounts.patch
sha256sums = 4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+ sha256sums = 0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb
pkgname = xfce4-places-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 2bfba4d0135e..86a56c1b415c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,26 @@
-# Maintainer: Alessio Sergi <asergi at archlinux dot us>
+# Maintainer: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Alessio Sergi <asergi at archlinux dot us>
+
pkgname=xfce4-places-plugin
pkgver=1.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="Places menu plugin for the Xfce panel"
arch=('i686' 'x86_64')
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
license=('GPL2')
depends=('libnotify' 'xfce4-panel')
makedepends=('intltool')
-source=("http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.bz2")
-sha256sums=('4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f')
+source=("http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.bz2"
+ "mounts.patch")
+sha256sums=('4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f'
+ '0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Show other mounts that are non disks (eg. NFS)
+ patch -Np1 -i "${srcdir}/mounts.patch"
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/mounts.patch b/mounts.patch
new file mode 100644
index 000000000000..44e5e0368562
--- /dev/null
+++ b/mounts.patch
@@ -0,0 +1,12 @@
+diff -Nur original/panel-plugin/model_volumes.c modified/panel-plugin/model_volumes.c
+--- original/panel-plugin/model_volumes.c 2013-12-28 11:30:18.000000000 +0000
++++ modified/panel-plugin/model_volumes.c 2015-06-25 09:59:34.324437370 +0100
+@@ -380,7 +380,7 @@
+ g_object_unref(mount);
+ }
+
+- return has_media && !is_shadowed;
++ return /*has_media &&*/ !is_shadowed;
+ }
+
+ static inline gboolean