summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2024-03-20 14:37:03 +0100
committerLone_Wolf2024-03-20 14:37:03 +0100
commit530c2c18ae79caccf4859b686b862e44ec17c6a7 (patch)
tree3ad42feaa473a6d16954c2f06a8df6fd088c3a7f
parentf574ec08ff38643b7bbbbca594f301e253f1f500 (diff)
downloadaur-530c2c18ae79caccf4859b686b862e44ec17c6a7.tar.gz
added !debug to options=
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 035ec857bce6..60a3a38982d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-minimal-git
- pkgver = 19.0.0_r492934.a02b79f3fc76
+ pkgver = 19.0.0_r493341.fb5fd2d82f9b
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -14,13 +14,14 @@ pkgbase = llvm-minimal-git
makedepends = python
makedepends = python-setuptools
options = !lto
+ options = !debug
source = git+https://github.com/llvm/llvm-project.git
md5sums = SKIP
sha512sums = SKIP
pkgname = llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies
- depends = llvm-libs-minimal-git=19.0.0_r492934.a02b79f3fc76-1
+ depends = llvm-libs-minimal-git=19.0.0_r493341.fb5fd2d82f9b-1
optdepends = python: for using lit (LLVM Integrated Tester)
optdepends = python-setuptools: for using lit
provides = llvm
@@ -53,14 +54,14 @@ pkgname = clang-minimal-git
pkgname = clang-libs-minimal-git
pkgdesc = clang runtime libraries, trunk version
- depends = llvm-libs-minimal-git=19.0.0_r492934.a02b79f3fc76-1
+ depends = llvm-libs-minimal-git=19.0.0_r493341.fb5fd2d82f9b-1
provides = clang-libs
- conflicts = clang<19.0.0_r492934.a02b79f3fc76-1
+ conflicts = clang<19.0.0_r493341.fb5fd2d82f9b-1
conflicts = clang-libs
pkgname = clang-opencl-headers-minimal-git
pkgdesc = clang headers & include files for OpenCL, trunk version
- depends = clang-libs-minimal-git=19.0.0_r492934.a02b79f3fc76-1
+ depends = clang-libs-minimal-git=19.0.0_r493341.fb5fd2d82f9b-1
provides = clang-opencl-headers
- conflicts = clang<19.0.0_r492934.a02b79f3fc76-1
+ conflicts = clang<19.0.0_r493341.fb5fd2d82f9b-1
conflicts = clang-opencl-headers
diff --git a/PKGBUILD b/PKGBUILD
index f020d2f250b4..29aa6effc9fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgbase=llvm-minimal-git
pkgname=(llvm-minimal-git llvm-libs-minimal-git clang-minimal-git clang-libs-minimal-git clang-opencl-headers-minimal-git)
-pkgver=19.0.0_r492934.a02b79f3fc76
+pkgver=19.0.0_r493341.fb5fd2d82f9b
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -26,13 +26,11 @@ makedepends=(git cmake libffi libedit ncurses libxml2
libxcrypt python python-setuptools)
source=("git+https://github.com/llvm/llvm-project.git"
)
-
md5sums=('SKIP')
sha512sums=('SKIP')
-
-options=('!lto')
-# explicitly disable lto to reduce number of build hangs / test failures and runtime issues
+# explicitly disable lto & debug to reduce number of build hangs , resources needed and runtime issues
+options=(!lto !debug )
# LIT by default uses all available cores. this can lead to heavy stress on systems making them unresponsive.
# It can also happen that the kernel oom killer interferes and kills important tasks.