summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2023-05-13 16:02:57 +0200
committerMartin Rys2023-05-13 16:02:57 +0200
commit559e11e5489990fce9d20d656d42db873c3a5eb3 (patch)
tree6c3d124b919cbae1a94e8a1067f115f87f2bb839
parent0af9f723d3bfef5af74926094a8079775838f1ed (diff)
downloadaur-559e11e5489990fce9d20d656d42db873c3a5eb3.tar.gz
Bump to 0.19.1/0.19.4
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rw-r--r--tbb.patch20
4 files changed, 41 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c759c978b445..28afa922fef4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
- pkgver = 0.18.6
+ pkgver = 0.19.1
pkgrel = 4
url = https://loot.github.io
arch = x86_64
@@ -23,11 +23,13 @@ pkgbase = loot
depends = libxss
depends = libxtst
depends = qt5-base
- source = loot-0.18.6.tar.gz::https://github.com/loot/loot/archive/0.18.6.tar.gz
- source = libloot-0.18.2.tar.gz::https://github.com/loot/libloot/archive/0.18.2.tar.gz
+ source = loot-0.19.1.tar.gz::https://github.com/loot/loot/archive/0.19.1.tar.gz
+ source = libloot-0.19.4.tar.gz::https://github.com/loot/libloot/archive/0.19.4.tar.gz
source = LOOT.desktop
- sha256sums = a93a5df1e34f3f54ec6023971433527776db6f8861be48e620e0f8c6a06169c5
- sha256sums = 1722cd816b302cae84bff26470831dc16c073236bc8a3728220f75cc3d19a3e0
+ source = tbb.patch
+ sha256sums = 832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1
+ sha256sums = 819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e
sha256sums = 3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb
+ sha256sums = 333e1c20367124242ebc8cf1153ca6925574a1b8de8f595e75d56fb3d83aa01e
pkgname = loot
diff --git a/.gitignore b/.gitignore
index a9f460abced0..269d51c991bf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!.SRCINFO
!PKGBUILD
!LOOT.desktop
+!tbb.patch
diff --git a/PKGBUILD b/PKGBUILD
index 85d0dd803e08..b7b537300921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Martin Rys <https://rys.pw/contact>
pkgname=loot
-pkgver=0.18.6
-_pkglibver=0.18.2
+pkgver=0.19.1
+_pkglibver=0.19.4
pkgrel=4
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
@@ -14,12 +14,20 @@ makedepends=('git' 'cmake' 'rust' 'cbindgen' 'boost')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
'LOOT.desktop'
+ 'tbb.patch' # https://github.com/loot/loot/issues/1864
)
-sha256sums=('a93a5df1e34f3f54ec6023971433527776db6f8861be48e620e0f8c6a06169c5'
- '1722cd816b302cae84bff26470831dc16c073236bc8a3728220f75cc3d19a3e0'
+sha256sums=('832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1'
+ '819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e'
'3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
+ '333e1c20367124242ebc8cf1153ca6925574a1b8de8f595e75d56fb3d83aa01e'
)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/tbb.patch"
+}
+
build() {
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"
@@ -56,5 +64,5 @@ package() {
# Install the icon
install -Dm644 "${_builddir}/../resources/icons/loot.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/loot.svg"
# Install desktop entry
- install -Dm644 ${srcdir}/../LOOT.desktop ${pkgdir}/usr/share/applications/LOOT.desktop
+ install -Dm644 "${srcdir}/../LOOT.desktop" "${pkgdir}/usr/share/applications/LOOT.desktop"
}
diff --git a/tbb.patch b/tbb.patch
new file mode 100644
index 000000000000..f9a63f3e7cdc
--- /dev/null
+++ b/tbb.patch
@@ -0,0 +1,20 @@
+--- a/src/gui/state/game/game.h
++++ b/src/gui/state/game/game.h
+@@ -26,6 +26,8 @@
+ #ifndef LOOT_GUI_STATE_GAME_GAME
+ #define LOOT_GUI_STATE_GAME_GAME
+
++#undef emit
++
+ #include <execution>
+ #include <filesystem>
+ #include <functional>
+@@ -34,6 +36,8 @@
+ #include <string>
+ #include <variant>
+
++#define emit
++
+ #include "gui/state/game/game_settings.h"
+ #include "gui/state/logging.h"
+ #include "loot/api.h"