summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-12-06 23:16:30 +0100
committerFabioLolix2020-12-06 23:16:30 +0100
commit588a1aa2a28c8362e1fcb2f6b05091ded629d5ee (patch)
tree3412300753578c8961c68ded7132edc65021f3cc
parent23f8e1a638e45b466d8082d7c99fc81b932a5ad6 (diff)
downloadaur-588a1aa2a28c8362e1fcb2f6b05091ded629d5ee.tar.gz
revision
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD43
2 files changed, 29 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14853e028f4f..27f354ac84fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = lgogdownloader
- pkgdesc = An open source downloader for GOG.com games, uses the GOG.com API
+ pkgdesc = Open source downloader for GOG.com games, uses the GOG.com API
pkgver = 3.7
- pkgrel = 1
+ pkgrel = 2
url = https://sites.google.com/site/gogdownloader/
arch = x86_64
- license = WTFPL
+ arch = i686
+ arch = pentium4
+ license = custom:WTFPL
makedepends = help2man
makedepends = cmake
- depends = boost
+ makedepends = boost
+ depends = boost-libs
depends = jsoncpp
- depends = liboauth
- depends = rhash
depends = tinyxml2
+ depends = rhash
depends = htmlcxx
- depends = curl
+ depends = qt5-webengine
source = http://sites.google.com/site/gogdownloader/lgogdownloader-3.7.tar.gz
sha256sums = 984859eb2e0802cfe6fe76b1fe4b90e7354e95d52c001b6b434e0a9f5ed23bf0
diff --git a/PKGBUILD b/PKGBUILD
index 3a833146990e..83a983efec5f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
-# Maintainer: Fabio Loli <no.email@given.net>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: C. Dominik Bódi <dominikdotbodiatgmxdotde>
+# Contributor: Joe Davison <joe@warhaggis.com>
pkgname=lgogdownloader
pkgver=3.7
-pkgrel=1
-pkgdesc="An open source downloader for GOG.com games, uses the GOG.com API"
+pkgrel=2
+pkgdesc="Open source downloader for GOG.com games, uses the GOG.com API"
url="https://sites.google.com/site/gogdownloader/"
-arch=('x86_64')
-license=('WTFPL')
-depends=('boost' 'jsoncpp' 'liboauth' 'rhash' 'tinyxml2' 'htmlcxx' 'curl')
-makedepends=('help2man' 'cmake')
-source=("http://sites.google.com/site/gogdownloader/$pkgname-$pkgver.tar.gz")
+arch=(x86_64 i686 pentium4)
+license=('custom:WTFPL')
+depends=(boost-libs jsoncpp tinyxml2 rhash htmlcxx qt5-webengine)
+makedepends=(help2man cmake boost)
+source=("http://sites.google.com/site/gogdownloader/${pkgname}-${pkgver}.tar.gz")
sha256sums=('984859eb2e0802cfe6fe76b1fe4b90e7354e95d52c001b6b434e0a9f5ed23bf0')
prepare() {
- cd $srcdir/$pkgname-$pkgver
-
- if [ ! -d "build" ]; then
- mkdir build
- else
- rm -rf build/*
- fi
-
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ [[ -d build ]] || mkdir build
}
build() {
- cd $srcdir/$pkgname-$pkgver/build
- make
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_QT_GUI=ON
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver/build
-
- make DESTDIR=$pkgdir install
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR=$pkgdir install
+ install -Dm644 ../COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}