aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Novikov2024-02-29 15:13:08 +0900
committerAndrey Novikov2024-02-29 15:13:08 +0900
commit58dfd8d0db6ffc44f65fe261c2c7a106bde96e5a (patch)
tree90b5eb23fc254eee0775d5ff2e969d984e9e1850
parent9a0702f3fc4b30f0ae67c8283db8ddc0e946b055 (diff)
downloadaur-58dfd8d0db6ffc44f65fe261c2c7a106bde96e5a.tar.gz
Fix build by applying most recent Go package guidelines
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e361208e916..abfa2cd02133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,11 @@ sha256sums=('5fbd046e2ac1c6b9b2a966ad6d174827f36e0f1dd82a20b609cb8c23a0d81632')
build() {
cd "$pkgname-$pkgver"
go build \
- -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
- -ldflags "-extldflags ${LDFLAGS}" \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
.
}