summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2022-04-14 20:39:41 -0400
committerPaul Hentschel (hpmachining)2022-04-14 20:39:41 -0400
commit591ca0f185ab6faeb5164ced2871622bb17318fe (patch)
tree882fcd24eb906056cae8015a97c22bce2f16dbdb
parentc8332631397503efd5d14d9b03d414306d274804 (diff)
downloadaur-591ca0f185ab6faeb5164ced2871622bb17318fe.tar.gz
Added patch to fix mime install issue.
-rw-r--r--.SRCINFO2
-rw-r--r--0001_mime.patch13
-rw-r--r--PKGBUILD9
3 files changed, 23 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e50331b8d8b6..e20ac27a6798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,8 @@ pkgbase = camotics-git
provides = camotics
conflicts = camotics
source = camotics::git+https://github.com/CauldronDevelopmentLLC/CAMotics.git#commit=master
+ source = 0001_mime.patch
sha256sums = SKIP
+ sha256sums = 162df92ac2523d561cdd82c87360b17ee2d715cfd567bcb8d00ae528994151e9
pkgname = camotics-git
diff --git a/0001_mime.patch b/0001_mime.patch
new file mode 100644
index 000000000000..8a1a9b2f617b
--- /dev/null
+++ b/0001_mime.patch
@@ -0,0 +1,13 @@
+diff --git a/SConstruct b/SConstruct
+index 369949a..bbe2f42 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -282,7 +282,7 @@ for target in docs + ['examples', 'machines']:
+ env.Install(prefix + '/share/camotics/', 'tpl_lib')
+ env.Install(prefix + '/share/pixmaps', 'images/camotics.png')
+ env.Install(prefix + '/share/applications', 'CAMotics.desktop')
+-env.Install(prefix + '/share/mime/packages/camotics.xml', 'mime.xml')
++env.InstallAs(prefix + '/share/mime/packages/camotics.xml', 'mime.xml')
+
+ description = '''CAMotics is an Open-Source software which can simulate
+ 3-axis NC machining. It is a fast, flexible and user friendly simulation
diff --git a/PKGBUILD b/PKGBUILD
index ae7335091d41..096ea29b27f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,21 @@ conflicts=('camotics')
_commit="master"
source=(
"${pkgname%-*}::git+https://github.com/CauldronDevelopmentLLC/CAMotics.git#commit=$_commit"
+ "0001_mime.patch"
)
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '162df92ac2523d561cdd82c87360b17ee2d715cfd567bcb8d00ae528994151e9')
pkgver() {
cd "${pkgname%-*}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${pkgname%-*}"
+ patch -p1 -i "../0001_mime.patch"
+}
+
build() {
cd "${pkgname%-*}"
mkdir -p build