aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-07-25 01:15:39 -0700
committerDonald Carr2016-07-25 01:15:39 -0700
commit5b6975c07b7fccb0c71ad8fdb3e47f40b57d45d9 (patch)
treec51b7dd50ef9f7b6e5e749b8a9671bd4e3d0ca7f
parent056a86686cb89bbb88ce0025c4f1a93fac145080 (diff)
downloadaur-5b6975c07b7fccb0c71ad8fdb3e47f40b57d45d9.tar.gz
Standardize all builds to a maintainable level
Change-Id: I6d5a7647b7898a2e1ca3f0700cf303a03c895cb4
-rw-r--r--PKGBUILD13
-rw-r--r--qpi.sh (renamed from qpi1.sh)0
-rw-r--r--qpi2.sh12
l---------qpi3.sh1
4 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cff4ae2a8d14..683878042b1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _static_build=false
_build_from_head=false
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
-pkgrel=14
+pkgrel=15
# 1 or 2 at present
_piver=""
@@ -94,12 +94,21 @@ _device_configure_flags=""
#Sanity check
__pkgconfigpath="${_sysroot}/usr/lib/pkgconfig"
+__eglpkgconfigpath="${__pkgconfigpath}/egl.pc"
+__glespkgconfigpath="${__pkgconfigpath}/glesv2.pc"
if [[ ! -d ${__pkgconfigpath} ]]; then
echo "You have to set a valid sysroot to proceed with the build"
exit 1
fi
+# Delete this is you know what you are doing
+# and want to build against Mesa
+if [[ -f ${__eglpkgconfigpath} ]] || [[ -f ${__glespkgconfigpath} ]] ; then
+ echo "Mesa is about to eat our communal poodle; delete egl.pc and glesv2.pc in your sysroot"
+ exit 1
+fi
+
#end sanity check
# callbacks
@@ -254,7 +263,7 @@ fi
local _libspkgdir="${_libsdir}/topkg"
local _libspkgbuild="${_libsdir}/PKGBUILD"
local _pkgprofiled=${_libspkgdir}/etc/profile.d
- local _profiledfn=qpi${_piver}.sh
+ local _profiledfn=qpi.sh
rm -Rf ${_libspkgdir}
mkdir -p ${_libspkgdir}
diff --git a/qpi1.sh b/qpi.sh
index 6a0ff925420c..6a0ff925420c 100644
--- a/qpi1.sh
+++ b/qpi.sh
diff --git a/qpi2.sh b/qpi2.sh
deleted file mode 100644
index 2be109b307ae..000000000000
--- a/qpi2.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-export QT_QPA_PLATFORM=wayland
-export QT_IM_MODULE=qtvirtualkeyboard
-export QT_WAYLAND_DISABLE_WINDOWDECORATION=1
-
-#Still a little raw
-#export QT_WAYLAND_USE_XDG_SHELL=1
-
-# Required as of 5.7.0 beta/RC
-export QSG_RENDER_LOOP=basic
-
-PATH="localpiprefix/bin:${PATH}"
-export PATH
diff --git a/qpi3.sh b/qpi3.sh
deleted file mode 120000
index 3e53fea82b3d..000000000000
--- a/qpi3.sh
+++ /dev/null
@@ -1 +0,0 @@
-qpi2.sh \ No newline at end of file