summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-11-08 09:40:35 +0200
committerAnton Kudelin2021-11-08 09:40:35 +0200
commit5bbb1bfd438d1cf9b84a1327bde36b2a6045553f (patch)
treed66af02296e81bfbe79a3312b1b1b0c55b09e02d
parent921105972160b9b543c5fa34eaa35fe5ac880ea5 (diff)
downloadaur-5bbb1bfd438d1cf9b84a1327bde36b2a6045553f.tar.gz
updated LAPACK to 3.10.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD80
2 files changed, 46 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d00b91eb27e..d00b0591ed6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = atlas-lapack
pkgdesc = Automatically Tuned Linear Algebra Software
pkgver = 3.10.3
- pkgrel = 5
- url = http://math-atlas.sourceforge.net/
+ pkgrel = 6
+ url = http://math-atlas.sourceforge.net
install = atlas-lapack.install
arch = x86_64
license = BSD
@@ -13,15 +13,15 @@ pkgbase = atlas-lapack
provides = lapack
provides = cblas
provides = atlas-lapack-base
- noextract = lapack-3.9.0.tar.gz
+ noextract = lapack-3.10.0.tar.gz
noextract = atlas3.10.3.tar.bz2
options = !makeflags
- source = lapack-3.9.0.tar.gz::https://github.com/Reference-LAPACK/lapack/archive/v3.9.0.tar.gz
+ options = !buildflags
+ source = lapack-3.10.0.tar.gz::https://github.com/Reference-LAPACK/lapack/archive/v3.10.0.tar.gz
source = http://downloads.sourceforge.net/math-atlas/atlas3.10.3.tar.bz2
source = Makefile
- sha256sums = 106087f1bb5f46afdfba7f569d0cbe23dacb9a07cd24733765a0e89dbe1ad573
+ sha256sums = 328c1bea493a32cac5257d84157dc686cc3ab0b004e2bea22044e0a59f6f8a19
sha256sums = 2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7
sha256sums = 7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69
pkgname = atlas-lapack
-
diff --git a/PKGBUILD b/PKGBUILD
index f2de3a61a907..51567495447d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Anton Kudelin <kudelin___AT___protonmail___DOT___com>
+# Maintainer: Anton Kudelin <kudelin___AT___protonmail___DOT___com>
# Contributor: Giuseppe Borzi <gborzi___AT___ieee___DOT___org>
# Contributor: mickele <mimocciola___AT___yahoo___DOT___ com>
# Contributor: iztok pizorn <pizorn___AT___gmail___DOT___com>
@@ -6,66 +6,66 @@
pkgname=atlas-lapack
pkgver=3.10.3
-_lapackver=3.9.0
-pkgrel=5
+_lapackver=3.10.0
+pkgrel=6
pkgdesc="Automatically Tuned Linear Algebra Software"
-url="http://math-atlas.sourceforge.net/"
+url="http://math-atlas.sourceforge.net"
depends=('gcc-libs')
makedepends=('gcc-fortran')
arch=('x86_64')
provides=('blas' 'lapack' 'cblas' 'atlas-lapack-base')
license=('BSD' 'custom:lapack')
-options=(!makeflags)
-install=$pkgname.install
source=("lapack-$_lapackver.tar.gz::https://github.com/Reference-LAPACK/lapack/archive/v$_lapackver.tar.gz"
"http://downloads.sourceforge.net/math-atlas/atlas$pkgver.tar.bz2"
"Makefile")
noextract=("lapack-$_lapackver.tar.gz" "atlas$pkgver.tar.bz2")
-sha256sums=('106087f1bb5f46afdfba7f569d0cbe23dacb9a07cd24733765a0e89dbe1ad573'
+sha256sums=('328c1bea493a32cac5257d84157dc686cc3ab0b004e2bea22044e0a59f6f8a19'
'2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7'
'7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69')
+options=(!makeflags !buildflags)
+install=$pkgname.install
prepare() {
- msg 'Before building this package, as root you must set the CPU(s)'
- msg 'governor(s) to "performance" and disable intel_pstate.'
- msg 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
-
- cd "$srcdir"
- tar -xjf atlas$pkgver.tar.bz2
- mkdir -p ATLAS/build
+ echo 'Before building this package, as root you must set the CPU(s)'
+ echo 'governor(s) to "performance" and disable intel_pstate.'
+ echo 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
+
+ cd "$srcdir"
+ tar -xjf atlas$pkgver.tar.bz2
+ mkdir -p ATLAS/build
}
build() {
- cd "$srcdir/ATLAS/build"
- ../configure --prefix=/usr \
- --shared \
- --with-netlib-lapack-tarfile="$srcdir/lapack-$_lapackver.tar.gz"
- make build
- cd lib
- cp "$srcdir/Makefile" .
- make
+ cd "$srcdir/ATLAS/build"
+ ../configure --prefix=/usr \
+ --shared \
+ --with-netlib-lapack-tarfile="$srcdir/lapack-$_lapackver.tar.gz"
+ make build
+ cd lib
+ cp "$srcdir/Makefile" .
+ make
}
check() {
- cd "$srcdir/ATLAS/build"
- make check F77FLAGS="$F77FLAGS -fallow-argument-mismatch"
- make ptcheck
- make time
+ cd "$srcdir/ATLAS/build"
+ make check F77FLAGS="$F77FLAGS -fallow-argument-mismatch"
+ make ptcheck
+ make time
}
package() {
- cd "$srcdir/ATLAS/build"
- make DESTDIR="$pkgdir/usr" install
- cp -d lib/*.so "$pkgdir/usr/lib"
- install -m755 lib/liblapack.so.3.6.1 "$pkgdir/usr/lib/liblapack.so.$_lapackver"
- install -m755 lib/libptlapack.so.3.6.1 "$pkgdir/usr/lib/libptlapack.so.$_lapackver"
- cd "$pkgdir/usr/lib"
- ln -s liblapack.so.$_lapackver liblapack.so.3
- ln -s liblapack.so.3 liblapack.so
- ln -s libblas.so libblas.so.3
- ln -s libcblas.so libcblas.so.3
- cd ../include/atlas
- sed -i "s#$srcdir# #g" *
- install -Dm644 "$srcdir/ATLAS/build/src/lapack/reference/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/lapack-license.txt"
+ cd "$srcdir/ATLAS/build"
+ make DESTDIR="$pkgdir/usr" install
+ cp -d lib/*.so "$pkgdir/usr/lib"
+ install -m755 lib/liblapack.so.3.6.1 "$pkgdir/usr/lib/liblapack.so.$_lapackver"
+ install -m755 lib/libptlapack.so.3.6.1 "$pkgdir/usr/lib/libptlapack.so.$_lapackver"
+ cd "$pkgdir/usr/lib"
+ ln -s liblapack.so.$_lapackver liblapack.so.3
+ ln -s liblapack.so.3 liblapack.so
+ ln -s libblas.so libblas.so.3
+ ln -s libcblas.so libcblas.so.3
+ cd ../include/atlas
+ sed -i "s#$srcdir# #g" *
+ install -Dm644 "$srcdir/ATLAS/build/src/lapack/reference/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/lapack-license.txt"
}