summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-04-07 07:32:54 +0800
committerlilac2021-04-07 07:32:54 +0800
commit5bf3c68354c3bd3358677896b41f8916dda462c8 (patch)
treed2194db266dcc07bf81df807e652ae95ab20976e
parent8fdefa91ee27eb4fe87fe48fbdaaa80dd70ee7fb (diff)
downloadaur-5bf3c68354c3bd3358677896b41f8916dda462c8.tar.gz
[lilac] updated to 2.6.3.r108.ged0ece30-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5739f928eba..b53bab426a7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keepassxc-git
pkgdesc = Cross-platform community-driven port of KeePass Password Safe
- pkgver = 2.6.3.r76.gf3d88fbd
- pkgrel = 1
+ pkgver = 2.6.3.r108.ged0ece30
+ pkgrel = 2
url = https://github.com/keepassxreboot/keepassxc
arch = i686
arch = x86_64
@@ -25,10 +25,8 @@ pkgbase = keepassxc-git
depends = qt5-svg
depends = qrencode
depends = quazip
- depends = libsodium
- depends = libgcrypt
- depends = argon2
depends = zlib
+ depends = botan
provides = org.freedesktop.secrets
conflicts = keepassxc
replaces = keepassx-http
diff --git a/PKGBUILD b/PKGBUILD
index 9e4d2f1cd634..25903ab2e284 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Daniel Landau <daniel@landau.fi>
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Contributor: Daniel Landau <daniel@landau.fi>
# Contributor: Maxqia <contrib@maxqia.com>
# The following people have contributed to keepassx-git package
@@ -9,8 +10,8 @@
pkgname=keepassxc-git
_gitname=keepassxc
-pkgver=2.6.3.r76.gf3d88fbd
-pkgrel=1
+pkgver=2.6.3.r108.ged0ece30
+pkgrel=2
pkgdesc="Cross-platform community-driven port of KeePass Password Safe"
arch=('i686' 'x86_64')
url="https://github.com/keepassxreboot/keepassxc"
@@ -18,7 +19,7 @@ license=('GPL2')
depends=('qt5-base' 'qt5-x11extras' 'qt5-translations' 'qt5-imageformats'
'libxtst' 'shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils'
'yubikey-personalization' 'qt5-svg' 'qrencode' 'quazip'
- 'libsodium' 'libgcrypt' 'argon2' 'zlib')
+ 'zlib' 'botan')
makedepends=('git' 'intltool' 'cmake' 'qt5-tools' 'asciidoctor')
checkdepends=('xorg-server-xvfb' 'xclip')
provides=(org.freedesktop.secrets)
@@ -30,26 +31,21 @@ md5sums=('SKIP')
pkgver() {
cd "${_gitname}"
- git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "${_gitname}"
- mkdir -p build
- sed -i'' -e 's:/usr/local/share/man/:${CMAKE_INSTALL_MANDIR}/:' src/cli/CMakeLists.txt
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_gitname}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cd "${_gitname}"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_BINDIR=/usr/bin \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_VERBOSE_MAKEFILE=OFF \
-DWITH_GUI_TESTS=ON \
-DWITH_XC_ALL=ON \
-DWITH_XC_KEESHARE_SECURE=ON \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
- make
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ make -C build
}
#check() {