summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTasos Sahanidis2020-12-18 07:06:39 +0200
committerTasos Sahanidis2020-12-18 07:08:11 +0200
commit5c3ba2e25e587c2c0ecd01028341f7b5c5f2e545 (patch)
treecde2fddca38a185a83c77ea3fc01db4e452d2b9e
parente32d0788e1f392df0833e4cba60d0e22fa1d5624 (diff)
downloadaur-5c3ba2e25e587c2c0ecd01028341f7b5c5f2e545.tar.gz
v0.4.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch28
3 files changed, 19 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95821811d09b..bca9d4e4e3b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ckb-next
pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
- pkgver = 0.4.2
- pkgrel = 6
+ pkgver = 0.4.3
+ pkgrel = 1
url = https://github.com/ckb-next/ckb-next
install = ckb-next.install
arch = i686
@@ -12,16 +12,18 @@ pkgbase = ckb-next
depends = qt5-base
depends = hicolor-icon-theme
depends = quazip
- optdepends = libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)
+ depends = qt5-tools
+ depends = libxcb
+ depends = xcb-util-wm
+ depends = qt5-x11extras
+ depends = libdbusmenu-qt5
optdepends = libpulse
provides = ckb-next
conflicts = ckb-git
conflicts = ckb-git-latest
conflicts = ckb-next-git
- source = https://github.com/ckb-next/ckb-next/archive/v0.4.2.tar.gz
- source = a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch
- sha256sums = 75b6908d5590c293dee8258a83d4ebe206306d3df9f867596e953ef7c6a86440
- sha256sums = 33eb682dfb0b0651fcf7e922978fb09ae07f072dabe538976a3b1ecf9115120f
+ source = https://github.com/ckb-next/ckb-next/archive/v0.4.3.tar.gz
+ sha256sums = e4fbd14227ecc63fad9eaf705ca61defd7b44bcaa3ad29aae18cd8a69bbc9ef9
pkgname = ckb-next
diff --git a/PKGBUILD b/PKGBUILD
index d6e6c38ef885..eaea9dedbf00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Tasos Sahanidis <aur@tasossah.com>
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
-pkgver=0.4.2
-pkgrel=6
+pkgver=0.4.3
+pkgrel=1
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64')
url="https://github.com/ckb-next/ckb-next"
license=('GPL2')
-depends=('qt5-base' 'hicolor-icon-theme' 'quazip')
+depends=('qt5-base' 'hicolor-icon-theme' 'quazip' 'qt5-tools' 'libxcb' 'xcb-util-wm' 'qt5-x11extras' 'libdbusmenu-qt5')
makedepends=('git' 'cmake')
-optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)' 'libpulse')
+optdepends=('libpulse')
conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git')
provides=('ckb-next')
install=ckb-next.install
-source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz"
- "a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch")
-sha256sums=('75b6908d5590c293dee8258a83d4ebe206306d3df9f867596e953ef7c6a86440'
- '33eb682dfb0b0651fcf7e922978fb09ae07f072dabe538976a3b1ecf9115120f')
+source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('e4fbd14227ecc63fad9eaf705ca61defd7b44bcaa3ad29aae18cd8a69bbc9ef9')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -32,10 +30,10 @@ build() {
cmake --build build --target all
}
-prepare() {
- cd "$srcdir/${pkgname}-${pkgver}"
- patch -p1 -i "$srcdir/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch"
-}
+#prepare() {
+# cd "$srcdir/${pkgname}-${pkgver}"
+# patch -p1 -i "$srcdir/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch"
+#}
package() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch b/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch
deleted file mode 100644
index e070471cdc02..000000000000
--- a/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a9f41cd8b8f5b04c0c66c6d94f96a9725943831e Mon Sep 17 00:00:00 2001
-From: Erik Zeek <zeekec@gmail.com>
-Date: Tue, 12 May 2020 09:56:49 -0600
-Subject: [PATCH] Fix gcc-10/-fno-common error
-
-gcc-10 now defaults to -fno-common and does not automatically add extern
-to variables declared in headers.
-
-https://gcc.gnu.org/gcc-10/porting_to.html
-
-Signed-off-by: Erik Zeek <zeekec@gmail.com>
----
- src/daemon/devnode.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/daemon/devnode.h b/src/daemon/devnode.h
-index a0b3a931..349e778d 100644
---- a/src/daemon/devnode.h
-+++ b/src/daemon/devnode.h
-@@ -5,7 +5,7 @@
- #include "usb.h"
-
- /// Device path base ("/dev/input/ckb" or "/var/run/ckb")
--const char *const devpath;
-+extern const char *const devpath;
-
- /// Group ID for the control nodes. -1 to give read/write access to everybody
- extern long gid;