summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2022-11-16 10:51:04 +0100
committerZacharias Knudsen2022-11-16 10:51:04 +0100
commit5e77857a32b029cf74df14141c344f71a91aeb32 (patch)
tree634e8bb03a6e9ef127704b8d484c6ae0aef20dd4
parent31467b6979bcbab4472a5721fe119d71fdaa3943 (diff)
downloadaur-5e77857a32b029cf74df14141c344f71a91aeb32.tar.gz
Remove prebuilt binaries
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 791058a9f0f3..442862d97c50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-unreal-tournament-goty
pkgdesc = Unreal Tournament (99): Game of the Year Edition. GOG Version.
pkgver = 469c
- pkgrel = 1
+ pkgrel = 2
url = https://www.gog.com/game/unreal_tournament_goty
arch = x86_64
license = MIT
@@ -14,12 +14,13 @@ pkgbase = gog-unreal-tournament-goty
license = Apache
license = custom
makedepends = innoextract
- depends = lib32-libgl
- depends = lib32-libpulse
- depends = lib32-sdl
- noextract = OldUnreal-UTPatch469c-Linux-amd64.tar.bz2
+ depends = mpg123
+ depends = openal
+ depends = sdl2
+ depends = libxmp
+ noextract = patch-469c.tar.bz2
source = setup_ut_goty.exe::gogdownloader://unreal_tournament_goty/en1installer0
- source = OldUnreal-UTPatch-Linux-amd64.tar.bz2::https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469c/OldUnreal-UTPatch469c-Linux-amd64.tar.bz2
+ source = patch-469c.tar.bz2::https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469c/OldUnreal-UTPatch469c-Linux-amd64.tar.bz2
source = gog-unreal-tournament-goty.desktop
source = fallback_dlagent.sh
sha256sums = 4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803
diff --git a/PKGBUILD b/PKGBUILD
index 379dc3e86ec2..24baff049f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=gog-unreal-tournament-goty
pkgver=469c
-pkgrel=1
+pkgrel=2
pkgdesc="Unreal Tournament (99): Game of the Year Edition. GOG Version."
arch=('x86_64')
url="https://www.gog.com/game/unreal_tournament_goty"
# https://github.com/OldUnreal/UnrealTournamentPatches/blob/master/LICENSE.md
license=('MIT' 'BSD' 'ZLIB' 'GPL2' 'LGPL2.1' 'ZLIB' 'OFL' 'Apache' 'custom')
-depends=('lib32-libgl'
- 'lib32-libpulse'
- 'lib32-sdl')
+depends=('mpg123' 'openal' 'sdl2' 'libxmp')
makedepends=('innoextract')
source=("setup_ut_goty.exe::gogdownloader://unreal_tournament_goty/en1installer0"
- "OldUnreal-UTPatch-Linux-amd64.tar.bz2::https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469c/OldUnreal-UTPatch469c-Linux-amd64.tar.bz2"
+ "patch-${pkgver}.tar.bz2::https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469c/OldUnreal-UTPatch469c-Linux-amd64.tar.bz2"
"gog-unreal-tournament-goty.desktop"
"fallback_dlagent.sh")
-noextract=("OldUnreal-UTPatch469c-Linux-amd64.tar.bz2")
+noextract=("patch-${pkgver}.tar.bz2")
sha256sums=("4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803"
"4c99bde06d26b724f14471d374d4d6105dbdc98c56ec2a40af3fa541956eeed9"
"4c507f98e74b3f6aa87cc1d8e48750afd4f0b33078337d5406efd0e46d256600"
@@ -25,17 +23,27 @@ sha256sums=("4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803"
# DLAGENTS+=('goggogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
DLAGENTS+=("gogdownloader::./fallback_dlagent.sh")
+# see
+# https://github.com/OldUnreal/UnrealTournamentPatches#linux-installation
prepare() {
- # extract gog installer
innoextract --extract --exclude-temp "setup_ut_goty.exe"
- # extract linux patches
- tar --extract --file "OldUnreal-UTPatch-Linux-amd64.tar.bz2" --directory "app"
+ tar --extract --file "patch-${pkgver}.tar.bz2" --one-top-level=unreal
+
+ cp --recursive "app/Music" "app/Sounds" "app/Maps" "unreal/"
+ cp --no-clobber app/Textures/* "unreal/Textures/"
+
+ # Remove prebuilt libraries in favor of arch/AUR packages
+ rm \
+ "unreal/System64/libmpg123.so" \
+ "unreal/System64/libopenal.so.1" \
+ "unreal/System64/libSDL2-2.0.so.0" \
+ "unreal/System64/libxmp.so.4"
# To put extra content (extra levels/mods) into the game
# create an "addons/" folder next to the PKGBUILD.
# Whatever is in there will get copied to the root of the game's directory.
- cp --archive ${startdir}/addons/* "app" 2>/dev/null || :
+ cp --archive ${startdir}/addons/* "unreal" 2>/dev/null || :
}
package() {
@@ -45,7 +53,7 @@ package() {
"${pkgdir}/usr/bin"
# copy game files
- cp --archive "app" "${pkgdir}/opt/gog/${pkgname#gog-}"
+ cp --archive "unreal" "${pkgdir}/opt/gog/${pkgname#gog-}"
# fix permissions (too extreme? what files actually need this?)
chmod 777 -R "${pkgdir}/opt/gog/${pkgname#gog-}"
@@ -60,6 +68,6 @@ package() {
"${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D --mode 644 \
- "app/LICENSE.md" \
+ "unreal/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}