summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-04-23 01:58:20 +0200
committerM0Rf302018-04-23 01:58:20 +0200
commit5f1babec3855d5b4f2fa5b47061a191bffd14ad6 (patch)
tree39c51a331b1cb61d4b12fd587f9662fab59a8cef
parent21c06d9eaca36b7b2908b01022a56af93812abd9 (diff)
downloadaur-5f1babec3855d5b4f2fa5b47061a191bffd14ad6.tar.gz
ocaml-camomile: better installation
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9b5142bfc5c..cb04ee489e31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,23 +15,30 @@ options=(!strip !makeflags staticlibs)
build() {
cd Camomile-${pkgver}
- make all
+ jbuilder build @install
}
check() {
cd Camomile-${pkgver}
- make test
+ jbuilder runtest
}
package() {
cd Camomile-${pkgver}
- # Initialize OPAM, this should be removed once opam is “removed” from dune
- export OPAMROOT="${srcdir}"/opam
- opam init -n
+ mkdir -p "$pkgdir"/usr/lib/ocaml
+ jbuilder install \
+ --destdir="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml"
- # Work around the install command
- make OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)" install
+ cd "$pkgdir"
+
+ # There's just a readme.
+ rm -Rf usr/doc
+
+ # Remove annotation files and sources.
+ rm -Rf usr/lib/ocaml/$_pkgname/*.cmt*
+ rm -Rf usr/lib/ocaml/$_pkgname/*.ml
}
md5sums=('9557fd86f13eba45474fc1336f225f32')