summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2022-01-07 15:58:52 +0200
committergardenapple2022-01-07 15:59:05 +0200
commit600b438af504374e1407ecfd4403820f6d786f83 (patch)
treec131cd0c1fd61957bd36eee01ac003dccf9171d3
parent3f347db9f6ccff77efd7ec7ebfcb8b7369d27bfc (diff)
downloadaur-600b438af504374e1407ecfd4403820f6d786f83.tar.gz
Add patch for python 3.10
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--fix-python-3.10.patch12
3 files changed, 30 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5319bbf8a268..733d8193ea8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fahcontrol-gtk3-git
pkgdesc = Graphical monitor and control utility for the Folding@home client (python3/GTK3 fork)
- pkgver = r181.02fc18c
+ pkgver = r183.f8cee6d
pkgrel = 1
url = https://foldingathome.org
arch = any
@@ -15,7 +15,8 @@ pkgbase = fahcontrol-gtk3-git
provides = fahcontrol
conflicts = fahcontrol
source = fahcontrol-gtk3-git::git+https://github.com/cdberkstresser/fah-control.git
+ source = fix-python-3.10.patch
sha256sums = SKIP
+ sha256sums = ca8c09a5b58582d7af8443be5e9653d6ebac2e0e9df387fc51c2e88c822f64db
pkgname = fahcontrol-gtk3-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1f5b1d996f88..a87f9b1bdceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: gardenapple <gardenapple@posteo.net>
# Contributor: katt <magunasu.b97@gmail.com>
+# Contributor: merlock <mlmatlock@gmail.com>
pkgname=fahcontrol-gtk3-git
-pkgver=r181.02fc18c
-pkgrel=2
+pkgver=r183.f8cee6d
+pkgrel=1
pkgdesc='Graphical monitor and control utility for the Folding@home client (python3/GTK3 fork)'
url='https://foldingathome.org'
arch=('any')
@@ -14,8 +15,15 @@ optdepends=('fahviewer: 3D simulation viewer')
provides=('fahcontrol')
conflicts=('fahcontrol')
#changelog="src/${pkgname}/CHANGELOG.md"
-source=("${pkgname}::git+https://github.com/cdberkstresser/fah-control.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/cdberkstresser/fah-control.git"
+ 'fix-python-3.10.patch')
+sha256sums=('SKIP'
+ 'ca8c09a5b58582d7af8443be5e9653d6ebac2e0e9df387fc51c2e88c822f64db')
+
+prepare() {
+ cd "$pkgname"
+ patch -p1 < "${srcdir}/fix-python-3.10.patch"
+}
pkgver() {
cd "$pkgname"
@@ -25,14 +33,14 @@ pkgver() {
}
build() {
- cd "${pkgname}"
+ cd "$pkgname"
python setup.py build
}
package() {
- cd "${pkgname}"
+ cd "$pkgname"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 FAHControl.desktop -t "${pkgdir}"/usr/share/applications
+ install -Dm644 FAHControl.desktop -t "${pkgdir}/usr/share/applications"
}
diff --git a/fix-python-3.10.patch b/fix-python-3.10.patch
new file mode 100644
index 000000000000..7c5f05fe74f9
--- /dev/null
+++ b/fix-python-3.10.patch
@@ -0,0 +1,12 @@
+diff --git a/fah/util/OrderedDict.py b/fah/util/OrderedDict.py
+index d19a916..edb9cbc 100644
+--- a/fah/util/OrderedDict.py
++++ b/fah/util/OrderedDict.py
+@@ -20,7 +20,7 @@
+ ################################################################################
+
+ from collections import UserDict
+-from collections import MutableMapping as DictMixin
++from collections.abc import MutableMapping as DictMixin
+
+ class OrderedDict(dict, DictMixin):