summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-06-19 09:29:10 -0500
committerDan Beste2017-06-19 09:29:10 -0500
commit611ddb0b62181c7f0092367e0cbe30da4770c27c (patch)
tree5e0464f897befc7ba10fed1c111339364cd6992c
parentb081e4e707021d264c3be2b6a1612967e7f54f87 (diff)
parentbd59c3d7608c3ded88dfdced06549d773b9787ea (diff)
downloadaur-611ddb0b62181c7f0092367e0cbe30da4770c27c.tar.gz
Merge conflict :(
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47a9f46644ba..dcc29573d9f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = libscrypt-git
makedepends = git
provides = libscrypt
conflicts = libscrypt
- source = git+https://github.com/technion/libscrypt
+ source = git+https://github.com/technion/libscrypt.git
sha256sums = SKIP
pkgname = libscrypt-git
diff --git a/PKGBUILD b/PKGBUILD
index 95eec8c9e114..090bfbabb1c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,23 @@ arch=('i686' 'x86_64')
url='https://github.com/technion/libscrypt'
license=('BSD')
makedepends=('git')
-provides=("${gitname}")
-conflicts=("${gitname}")
-source=('git+https://github.com/technion/libscrypt')
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=('git+https://github.com/technion/libscrypt.git')
sha256sums=('SKIP')
pkgver() {
cd "${_gitname}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/v//'
+ git describe --long \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
+ | sed 's/v//'
}
build() {
cd "${_gitname}"
CFLAGS="${CFLAGS} -fPIC"
-
make
}