summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Baz2019-08-30 17:38:19 +0200
committerMaxim Baz2019-08-30 17:38:19 +0200
commit621ea0cc16b9b3996b7939a101fdcdc49e01c14f (patch)
tree689fd5f7b9af6a599bb11231dc087ae33c6833b9
parent2d4e34d7aa9c2ebc23c6fea867f606d8fdc8178e (diff)
downloadaur-621ea0cc16b9b3996b7939a101fdcdc49e01c14f.tar.gz
wire-desktop-beta: 3.10.2904
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f402c35497b..0b88495f3b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wire-desktop-beta
pkgdesc = End-to-end encrypted messenger with file sharing, voice calls and video conferences
- pkgver = 3.9.2895
+ pkgver = 3.10.2904
pkgrel = 1
url = https://wire.com/
arch = any
@@ -8,14 +8,14 @@ pkgbase = wire-desktop-beta
makedepends = git
makedepends = npm
makedepends = yarn
- depends = electron
+ depends = electron4
depends = xdg-utils
optdepends = emoji-font: colorful emoji
- source = wire-desktop-beta-3.9.2895.tar.gz::https://github.com/wireapp/wire-desktop/archive/linux/3.9.2895.tar.gz
- source = wire-desktop-beta-3.9.2895.tar.gz.sig::https://github.com/wireapp/wire-desktop/releases/download/linux%2F3.9.2895/wire-desktop-linux-3.9.2895.tar.gz.sig
+ source = wire-desktop-beta-3.10.2904.tar.gz::https://github.com/wireapp/wire-desktop/archive/linux/3.10.2904.tar.gz
+ source = wire-desktop-beta-3.10.2904.tar.gz.sig::https://github.com/wireapp/wire-desktop/releases/download/linux%2F3.10.2904/wire-desktop-linux-3.10.2904.tar.gz.sig
source = wire-desktop-beta.desktop
validpgpkeys = ABBA007D6E14E2DB5B283C45D599C1AA126762B1
- sha256sums = 852de3b3eddce0611432d1249303a6e99bdf1450ac26aa60858e216b10562e6f
+ sha256sums = 25eec808ecd2bed5506749cc29c8ed5534dc455cf153d8e40ad933b68dfff031
sha256sums = SKIP
sha256sums = 35e522978ac21f7aa2f67faa712037d8999482eed1b88953dbea5420a9b13196
diff --git a/PKGBUILD b/PKGBUILD
index 9a4fdea30785..37a15595aa46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
pkgname=wire-desktop-beta
_pkgname=${pkgname%-beta}
-pkgver=3.9.2895
+pkgver=3.10.2904
pkgrel=1
pkgdesc='End-to-end encrypted messenger with file sharing, voice calls and video conferences'
arch=('any')
url='https://wire.com/'
license=('GPL3')
-depends=('electron' 'xdg-utils')
+depends=('electron4' 'xdg-utils')
makedepends=('git' 'npm' 'yarn')
optdepends=('emoji-font: colorful emoji')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wireapp/${_pkgname}/archive/linux/${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.sig::https://github.com/wireapp/${_pkgname}/releases/download/linux%2F${pkgver}/${_pkgname}-linux-${pkgver}.tar.gz.sig"
"${pkgname}.desktop")
-sha256sums=('852de3b3eddce0611432d1249303a6e99bdf1450ac26aa60858e216b10562e6f'
+sha256sums=('25eec808ecd2bed5506749cc29c8ed5534dc455cf153d8e40ad933b68dfff031'
'SKIP'
'35e522978ac21f7aa2f67faa712037d8999482eed1b88953dbea5420a9b13196')
validpgpkeys=('ABBA007D6E14E2DB5B283C45D599C1AA126762B1')
@@ -25,21 +25,21 @@ prepare() {
cat << EOF > "${pkgname}"
#!/usr/bin/env sh
-electron "/usr/lib/${pkgname}" "\$@"
+electron4 "/usr/lib/${pkgname}" "\$@"
EOF
}
build() {
cd "${_pkgname}-linux-${pkgver}"
yarn
- yarn build:ts
- BUILD_NUMBER="${pkgver##*.}" npx grunt 'linux-package'
+ sed -i '/Promise.all/d' node_modules/@wireapp/build-tools/dist/cli/build-linux-cli.js
+ BUILD_NUMBER="${pkgver##*.}" LINUX_TARGET=dir yarn build:linux:internal
}
package() {
# Place files
install -d "${pkgdir}/usr/lib/${pkgname}"
- cp -a "${_pkgname}-linux-${pkgver}/electron/"* "${pkgdir}/usr/lib/${pkgname}"
+ cp -a "${_pkgname}-linux-${pkgver}/wrap/dist/linux-unpacked/resources/app/"{electron,node_modules,package.json} "${pkgdir}/usr/lib/${pkgname}"
# Place launcher script
install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"