summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-04-02 10:11:40 +0200
committerBlair Bonnett2022-04-02 10:11:40 +0200
commit62a62e62c5792a80ab1d14f4279b033a483e81d4 (patch)
tree91db6c9688bff724078234d00d7aebb4ac553fbb
parent62dded30985b30945047ffa2d40458d845fa0c21 (diff)
downloadaur-62a62e62c5792a80ab1d14f4279b033a483e81d4.tar.gz
Update to 1.0.0.
Also switch to PEP517 builder.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 532942cb5d55..6fec22a8f3a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-h5netcdf
pkgdesc = Pythonic interface to netCDF4 via h5py
- pkgver = 0.15.0
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/shoyer/h5netcdf
arch = any
license = BSD
checkdepends = python-netcdf4
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-setuptools-scm
+ makedepends = python-setuptools-scm-git-archive
+ makedepends = python-wheel
depends = python-h5py
- source = https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-0.15.0.tar.gz
- sha256sums = 4b2b873ba72091c5e70c2a7bdb272ad0408b6e05a648aedb5ea96992b5f12138
+ source = https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-1.0.0.tar.gz
+ sha256sums = 4bf07ac545e6e4ee372a8505ffcee5c83f2db8b9a5c4a510b9336d92c3d50fa6
pkgname = python-h5netcdf
diff --git a/PKGBUILD b/PKGBUILD
index 18e129847daa..5f8e0b659fac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,17 @@
# Contributor: richli <rich at dranek dot com>
pkgname=python-h5netcdf
-pkgver=0.15.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="Pythonic interface to netCDF4 via h5py"
arch=('any')
url="https://github.com/shoyer/h5netcdf"
license=('BSD')
depends=('python-h5py')
-makedepends=('python-setuptools' 'python-setuptools-scm')
+makedepends=(
+ 'python-build' 'python-installer' 'python-setuptools' 'python-setuptools-scm'
+ 'python-setuptools-scm-git-archive' 'python-wheel'
+)
checkdepends=('python-netcdf4' 'python-pytest')
_pypi=h5netcdf
@@ -17,22 +20,23 @@ source=(
"https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- '4b2b873ba72091c5e70c2a7bdb272ad0408b6e05a648aedb5ea96992b5f12138'
+ '4bf07ac545e6e4ee372a8505ffcee5c83f2db8b9a5c4a510b9336d92c3d50fa6'
)
build() {
cd "$_pypi-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
+
}
check() {
cd "$_pypi-${pkgver}"
- PYTHONPATH="./build/lib" PYTHONDONTWRITEBYTECODE=1 pytest -v --disable-warnings
+ PYTHONPATH="./build/lib" pytest -v --disable-warnings
}
package() {
cd "$_pypi-${pkgver}"
- python setup.py install --prefix=/usr --root="$pkgdir" --skip-build --optimize 1
+ python -m installer --destdir="$pkgdir" "dist/$_pypi-$pkgver-"*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}