summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2022-09-21 23:28:47 +1000
committerRhinoceros2022-09-21 23:28:47 +1000
commit64aee5d1e0f92b360874c6c4aac1bfbed165e040 (patch)
treeb10e2ad78072ca83a38526fc84c129eb30579d8a
parentde4343f872e070efc4ed32765acc394c0c33345c (diff)
downloadaur-64aee5d1e0f92b360874c6c4aac1bfbed165e040.tar.gz
Update to 1:1.4.1.0-1
* Upstream changelog: * General incremental update. * Fixed multipart/segment file/name headers with whitespace/quoted strings. * Added 'make debug' * Fixed potential bug in pldstr PLD_strtok() where comparison between ptr and char was being made instead of char =? char. * Cleaned up some compiler warnings * Move to proper versioned release; upstream tagged a release. * Remove redundant makedepends (git), other changes for release. * Fix pkgdesc as per upstream * Minor style fixes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bea6d77d77d..0b936f1bf47f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = ripmime
- pkgdesc = MIME/email package decoder
- pkgver = r18
+ pkgdesc = Email attachment extractor
+ pkgver = 1.4.1.0
pkgrel = 1
epoch = 1
url = https://github.com/inflex/ripMIME
arch = any
license = BSD
- makedepends = git
conflicts = ripmime-git
- source = git+https://github.com/inflex/ripmime.git#commit=20266ed9ddefafe7c6b9f3c6bbf869d6facab0e9
- sha256sums = SKIP
+ source = ripmime-1.4.1.0.tar.gz::https://github.com/inflex/ripmime/archive/1.4.1.0.tar.gz
+ sha256sums = 6d551d6b65b4da6c6b8dfd05be8141026cc760ca1fb8a707b7bf96c199c9f52d
pkgname = ripmime
diff --git a/PKGBUILD b/PKGBUILD
index a5918d731286..cc9c37f7e883 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,25 @@
# Contributor: K. Piche <kpiche <at> rogers <dot> com>
pkgname=ripmime
-pkgver=r18
-_commit=20266ed9ddefafe7c6b9f3c6bbf869d6facab0e9
+_pkgname=ripMIME
+pkgver=1.4.1.0
pkgrel=1
epoch=1
-pkgdesc='MIME/email package decoder'
+pkgdesc='Email attachment extractor'
arch=(any)
-url="https://github.com/inflex/ripMIME"
+url='https://github.com/inflex/ripMIME'
license=('BSD')
conflicts=('ripmime-git')
-source=("git+https://github.com/inflex/${pkgname}.git#commit=$_commit")
-sha256sums=('SKIP')
-makedepends=('git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/inflex/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('6d551d6b65b4da6c6b8dfd05be8141026cc760ca1fb8a707b7bf96c199c9f52d')
build() {
- cd "${pkgname}"
+ cd "$_pkgname-$pkgver"
make
}
package() {
- cd "${pkgname}"
+ cd "$_pkgname-$pkgver"
mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/man/man1"
make LOCATION="${pkgdir}/usr" install