summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-08-07 09:12:01 -0400
committerTed Alff2017-08-07 09:12:01 -0400
commit65709e07c0db26dfad0c5b2dda34e044fdadfdaa (patch)
treeb6d4de7dd843eaa6afa43200f66909b3ddba8dec
parentaf1b0a5562654031ebc898752681cf1f32cac655 (diff)
downloadaur-65709e07c0db26dfad0c5b2dda34e044fdadfdaa.tar.gz
Updated with working PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--my-weather-indicator.install16
3 files changed, 31 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ddd7de57416..51a182a5d1bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Aug 7 13:11:43 UTC 2017
pkgbase = my-weather-indicator-git
pkgdesc = A simple indicator for the weather
- pkgver = r30.b8fb5fb
+ pkgver = r44.e5c76af
pkgrel = 1
url = https://launchpad.net/my-weather-indicator
- install = my-weather-indicator.install
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = libappindicator-gtk3
- makedepends = python-distutils-extra
- depends = gtk3
- depends = glib2
+ makedepends = python2-distutils-extra
+ makedepends = python2-polib
+ depends = libappindicator-gtk3
depends = libnotify
depends = webkitgtk
depends = geocode-glib
@@ -19,12 +19,12 @@ pkgbase = my-weather-indicator-git
depends = python-cairo
depends = python-lxml
depends = python-dateutil
- depends = python2-requests-oauthlib
+ depends = python-requests-oauthlib
depends = geoclue2
depends = geoip
provides = my-weather-indicator
conflicts = my-weather-indicator
- source = my-weather-indicator-git::git+https://git.launchpad.net/my-weather-indicator
+ source = my-weather-indicator::git+https://git.launchpad.net/my-weather-indicator
sha256sums = SKIP
pkgname = my-weather-indicator-git
diff --git a/PKGBUILD b/PKGBUILD
index bf1ef577568e..5c2818979116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,44 @@
# Maintainer: Luigi Guevara <@killua99>
+# Maintainer: twa022 <twa022 at gmail dot com>
# Author: Lorenzo Carbonell <lorenzo.carbonell.cerezo@gmail.com>
_pkgname=my-weather-indicator
pkgname=my-weather-indicator-git
-pkgver=r30.b8fb5fb
+pkgver=r44.e5c76af
pkgrel=1
pkgdesc='A simple indicator for the weather'
arch=('i686' 'x86_64')
url='https://launchpad.net/my-weather-indicator'
license=('GPL3')
-depends=('gtk3' 'glib2' 'libnotify' 'webkitgtk' 'geocode-glib' 'python-pytz'
+depends=('libappindicator-gtk3' 'libnotify' 'webkitgtk' 'geocode-glib' 'python-pytz'
'python-cairo' 'python-lxml' 'python-dateutil'
- 'python2-requests-oauthlib' 'geoclue2' 'geoip')
-makedepends=('git' 'libappindicator-gtk3' 'python-distutils-extra')
-provides=('my-weather-indicator')
-conflicts=('my-weather-indicator')
-install='my-weather-indicator.install'
-source=($pkgname::git+https://git.launchpad.net/my-weather-indicator)
+ 'python-requests-oauthlib' 'geoclue2' 'geoip')
+makedepends=('git' 'python2-distutils-extra' 'python2-polib')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://git.launchpad.net/my-weather-indicator")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir"
+ cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
+prepare() {
+ cd "${_pkgname}"
- mkdir -p "$pkgdir/opt/$_pkgname"
+ # Don't install to /opt and install locales to correct directory
+ find . -type f -exec \
+ sed -i -e 's:/opt/extras.ubuntu.com/my-weather-indicator:/usr:g' \
+ -e 's:locale-langpack:locale:g' '{}' \;
+}
- install -D -m644 "${pkgdir}/opt/${$pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+build() {
+ cd "${_pkgname}"
+ python2 setup.py build
}
-# vim: ts=2 sw=2 et:
+package() {
+ cd "${_pkgname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
diff --git a/my-weather-indicator.install b/my-weather-indicator.install
deleted file mode 100644
index b1b744355dff..000000000000
--- a/my-weather-indicator.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- glib-compile-schemas usr/share/glib-2.0/schemas
- update-desktop-database -q
-}
-
-post_upgrade()
-{
- post_install
-}
-
-post_remove()
-{
- post_install
-}
-
-# vim: ts=2 sw=2 et: