summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2022-01-26 14:29:31 -0500
committerDavid Wells2022-01-26 14:29:31 -0500
commit658826e6dea6bdd60e7319e3dd235e5d6ab7f801 (patch)
tree0079bb8e014f6e1027c2c0877c195717367b5d4c
parent9545990b9306af073c5f561e30f93e508610c10b (diff)
downloadaur-658826e6dea6bdd60e7319e3dd235e5d6ab7f801.tar.gz
Up to 9.3.3
We also need to disable SUNDIALS support for now.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cd21d73e17b..6819faf8a888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
- pkgver = 9.3.1
- pkgrel = 2
+ pkgver = 9.3.3
+ pkgrel = 1
url = http://www.dealii.org/
install = deal-ii.install
arch = i686
@@ -30,7 +30,7 @@ pkgbase = deal-ii
optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
optdepends = suitesparse: A collection of sparse matrix libraries
optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
- source = https://github.com/dealii/dealii/releases/download/v9.3.1/dealii-9.3.1.tar.gz
- sha1sums = d7aeb5aa397d2299fd9ffc8e82ba0408eeb9d8fc
+ source = https://github.com/dealii/dealii/releases/download/v9.3.3/dealii-9.3.3.tar.gz
+ sha1sums = 297cb9aad508396528c8f65be379e0a1f05d2e79
pkgname = deal-ii
diff --git a/PKGBUILD b/PKGBUILD
index aa15afce1561..018337e538c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=deal-ii
_realname=dealii
-pkgver=9.3.1
-pkgrel=2
+pkgver=9.3.3
+pkgrel=1
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -31,7 +31,7 @@ optdepends=(
'petsc: Portable, extensible toolkit for scientific computation'
'scalapack: subset of scalable LAPACK routines redesigned for distributed memory MIMD parallel computers'
'slepc: Scalable library for Eigenvalue problem computations'
- # deal.II is not compatible with sundials 4.0 or newer yet
+ # deal.II is not compatible with sundials 6.0 or newer yet
# 'sundials: Suite of nonlinear differential/algebraic equation solvers'
'symengine: Fast symbolic manipulation library'
'tbb: High level abstract threading library'
@@ -42,7 +42,7 @@ optdepends=(
makedepends=('cmake')
install=deal-ii.install
source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
-sha1sums=('d7aeb5aa397d2299fd9ffc8e82ba0408eeb9d8fc')
+sha1sums=('297cb9aad508396528c8f65be379e0a1f05d2e79')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
_installation_prefix=/usr
@@ -129,6 +129,7 @@ build() {
-DCMAKE_INSTALL_MESSAGE=NEVER -DCMAKE_CXX_FLAGS=" $extra_warning_flags" \
-DDEAL_II_SHARE_RELDIR=share/${pkgname}/ \
-DDEAL_II_EXAMPLES_RELDIR=share/${pkgname}/examples/ \
+ -DDEAL_II_WITH_SUNDIALS=OFF \
-DDEAL_II_COMPONENT_DOCUMENTATION=OFF ${srcdir}/${_realname}-$pkgver
# deal.II needs about 3 GB/compilation process so use fewer jobs if your