summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2024-02-17 21:30:38 -0800
committerDonald Webster2024-02-17 21:30:38 -0800
commit65c5f519c8039a3c6bc71dc79230cbf2039e8c71 (patch)
tree6490d7f385fc611b1d859d29a012baccbd9f9864
parent151e5fa5508dc6d768b729732850f7ba075710dd (diff)
downloadaur-65c5f519c8039a3c6bc71dc79230cbf2039e8c71.tar.gz
Update to v3.1.2 and make xdg.patch more generic.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--xdg.patch29
3 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 913cf68551fc..c8212f72a762 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tmuxinator
pkgdesc = Manage complex tmux sessions easily
- pkgver = 3.1.1
+ pkgver = 3.1.2
pkgrel = 1
url = https://github.com/aziz/tmuxinator
arch = any
@@ -12,9 +12,9 @@ pkgbase = tmuxinator
depends = ruby-xdg5
optdepends = zsh-completions: for ZSH completion
options = !emptydirs
- source = tmuxinator-3.1.1.tar.gz::https://github.com/aziz/tmuxinator/archive/v3.1.1.tar.gz
+ source = tmuxinator-3.1.2.tar.gz::https://github.com/aziz/tmuxinator/archive/v3.1.2.tar.gz
source = xdg.patch
- sha256sums = e9be8001042c735d49ec94398a69e65308d9d0ca6bacc0e9fd947c37d53e250c
- sha256sums = 75d32aa7e9e7061a21ecb72bd4d3a76ea8610ec391a6dad1797d511cc8544ffb
+ sha256sums = f173d3481f01ad6321e639fa07473715c5f2210dad4b073bd0d1d87087f80785
+ sha256sums = bf91cc99026b1b465b00085512138df4717123ebb841acfb935c80162d14b0ba
pkgname = tmuxinator
diff --git a/PKGBUILD b/PKGBUILD
index f2ffd81d205f..86a5f07283f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Luca Cesari < luca AT cesari DOT me>
pkgname=tmuxinator
-pkgver=3.1.1
+pkgver=3.1.2
pkgrel=1
pkgdesc="Manage complex tmux sessions easily"
arch=(any)
@@ -22,8 +22,8 @@ source=(
"${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"xdg.patch"
)
-sha256sums=('e9be8001042c735d49ec94398a69e65308d9d0ca6bacc0e9fd947c37d53e250c'
- '75d32aa7e9e7061a21ecb72bd4d3a76ea8610ec391a6dad1797d511cc8544ffb')
+sha256sums=('f173d3481f01ad6321e639fa07473715c5f2210dad4b073bd0d1d87087f80785'
+ 'bf91cc99026b1b465b00085512138df4717123ebb841acfb935c80162d14b0ba')
prepare() {
cd ${pkgname}-${pkgver}
diff --git a/xdg.patch b/xdg.patch
index 274f39a4d3ab..4a495cc25cc9 100644
--- a/xdg.patch
+++ b/xdg.patch
@@ -1,8 +1,7 @@
-diff --git a/lib/tmuxinator/config.rb b/lib/tmuxinator/config.rb
-index d14eb9a..d4eccaa 100644
---- a/lib/tmuxinator/config.rb
-+++ b/lib/tmuxinator/config.rb
-@@ -29,7 +29,7 @@ module Tmuxinator
+diff -BurN tmuxinator-3.1.2.orig/lib/tmuxinator/config.rb tmuxinator-3.1.2/lib/tmuxinator/config.rb
+--- tmuxinator-3.1.2.orig/lib/tmuxinator/config.rb 2024-02-16 15:37:37.000000000 -0800
++++ tmuxinator-3.1.2/lib/tmuxinator/config.rb 2024-02-17 21:25:24.745199728 -0800
+@@ -29,7 +29,7 @@
# a custom value. (e.g. if $XDG_CONFIG_HOME is set to ~/my-config, the
# return value will be ~/my-config/tmuxinator)
def xdg
@@ -11,11 +10,10 @@ index d14eb9a..d4eccaa 100644
end
def xdg?
-diff --git a/spec/lib/tmuxinator/config_spec.rb b/spec/lib/tmuxinator/config_spec.rb
-index 09ab25f..9d6d7e2 100644
---- a/spec/lib/tmuxinator/config_spec.rb
-+++ b/spec/lib/tmuxinator/config_spec.rb
-@@ -53,7 +53,8 @@ describe Tmuxinator::Config do
+diff -BurN tmuxinator-3.1.2.orig/spec/lib/tmuxinator/config_spec.rb tmuxinator-3.1.2/spec/lib/tmuxinator/config_spec.rb
+--- tmuxinator-3.1.2.orig/spec/lib/tmuxinator/config_spec.rb 2024-02-16 15:37:37.000000000 -0800
++++ tmuxinator-3.1.2/spec/lib/tmuxinator/config_spec.rb 2024-02-17 21:25:24.745199728 -0800
+@@ -53,7 +53,8 @@
Dir.mktmpdir do |dir|
config_parent = "#{dir}/non_existent_parent/s"
@@ -25,7 +23,7 @@ index 09ab25f..9d6d7e2 100644
expect(described_class.directory).
to eq "#{config_parent}/tmuxinator"
expect(File.directory?("#{config_parent}/tmuxinator")).to be true
-@@ -134,7 +135,8 @@ describe Tmuxinator::Config do
+@@ -134,7 +135,8 @@
describe "#xdg" do
it "is $XDG_CONFIG_HOME/tmuxinator" do
@@ -35,11 +33,10 @@ index 09ab25f..9d6d7e2 100644
end
end
-diff --git a/tmuxinator.gemspec b/tmuxinator.gemspec
-index df933d8..f8e9fe7 100644
---- a/tmuxinator.gemspec
-+++ b/tmuxinator.gemspec
-@@ -41,7 +41,7 @@ Gem::Specification.new do |s|
+diff -BurN tmuxinator-3.1.2.orig/tmuxinator.gemspec tmuxinator-3.1.2/tmuxinator.gemspec
+--- tmuxinator-3.1.2.orig/tmuxinator.gemspec 2024-02-16 15:37:37.000000000 -0800
++++ tmuxinator-3.1.2/tmuxinator.gemspec 2024-02-17 21:25:24.745199728 -0800
+@@ -41,7 +41,7 @@
s.add_dependency "erubis", "~> 2.6"
s.add_dependency "thor", "~> 1.3.0"