summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeitian Leung2016-10-11 19:58:40 +0800
committerWeitian Leung2016-10-11 19:58:40 +0800
commit68ab5c76eafdfe25b900202e0d4cc84410f1beca (patch)
treea96916878f3b888f4f189dfe47f4db962bb93675
parent29af4483d8fd53ed4a094891539566d1c7a4f3ea (diff)
downloadaur-68ab5c76eafdfe25b900202e0d4cc84410f1beca.tar.gz
a bit improvement to the autostart scipt and PKGBUILD
change the connection url to bing checksums changed to sha512sums
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rwxr-xr-xbing-wallpaper-autostart.sh6
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f3a0258c9fd..611464e710fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 25 14:20:23 UTC 2016
+# Tue Oct 11 11:58:08 UTC 2016
pkgbase = bing-wallpaper-git
pkgdesc = Change wallpaper from Bing daily
pkgver = r29
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/marguerite/linux-bing-wallpaper
arch = any
license = GPL3
@@ -15,9 +15,9 @@ pkgbase = bing-wallpaper-git
source = bing-wallpaper-git::git+https://github.com/marguerite/linux-bing-wallpaper.git
source = bing-wallpaper-autostart.sh
source = bing-wallpaper.desktop
- md5sums = SKIP
- md5sums = 056c9b4f32857e684536b42a972ea0fc
- md5sums = 1e65c7c30461dcc752f4766e5a14bc76
+ sha512sums = SKIP
+ sha512sums = 131de9d1c55eb74760869d5ebaf64b722c43cafa2be90a3413d5e0d8c60bc62190825d44ba9155275bf3868d0b37869e3ad51878cf1d6d611562c4ba5b814c76
+ sha512sums = 83025c7c9e1957488f1e4bb385b599e8f17ca778a614f2bf8759cc99a9754e360ff1ecb8188eef7f9a7dbb8d2c6f93e6af4c8f441f88a6b2973e9737777b2d49
pkgname = bing-wallpaper-git
diff --git a/PKGBUILD b/PKGBUILD
index a5c762f8d3dc..9f3c872d701f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bing-wallpaper-git
pkgver=r29
-pkgrel=2
+pkgrel=3
pkgdesc="Change wallpaper from Bing daily"
arch=(any)
url="https://github.com/marguerite/linux-bing-wallpaper"
@@ -14,22 +14,24 @@ makedepends=('git')
source=("$pkgname::git+https://github.com/marguerite/linux-bing-wallpaper.git"
'bing-wallpaper-autostart.sh'
'bing-wallpaper.desktop')
-md5sums=('SKIP'
- '056c9b4f32857e684536b42a972ea0fc'
- '1e65c7c30461dcc752f4766e5a14bc76')
+sha512sums=('SKIP'
+ '131de9d1c55eb74760869d5ebaf64b722c43cafa2be90a3413d5e0d8c60bc62190825d44ba9155275bf3868d0b37869e3ad51878cf1d6d611562c4ba5b814c76'
+ '83025c7c9e1957488f1e4bb385b599e8f17ca778a614f2bf8759cc99a9754e360ff1ecb8188eef7f9a7dbb8d2c6f93e6af4c8f441f88a6b2973e9737777b2d49')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
printf "r%s" "$(git rev-list --count HEAD)"
}
package() {
- install -d "$pkgdir/usr/lib/bing-wallpaper"
- cp "$srcdir/$pkgname/"*.sh "$pkgdir/usr/lib/bing-wallpaper"
+ install -d -m 755 "${pkgdir}/usr/lib/bing-wallpaper"
+ install -d -m 755 "${pkgdir}/usr/bin"
+ install -d -m 755 "${pkgdir}/etc/xdg/autostart"
- install -d "$pkgdir/usr/bin"
- cp bing-wallpaper-autostart.sh "$pkgdir/usr/bin"
+ install -m 755 "${srcdir}/${pkgname}/bing_wallpaper.sh" "${pkgdir}/usr/lib/bing-wallpaper"
+ install -m 755 "${srcdir}/${pkgname}/kde4_set_wallpaper.sh" "${pkgdir}/usr/lib/bing-wallpaper"
+ install -m 755 "${srcdir}/${pkgname}/xfce4_set_wallpaper.sh" "${pkgdir}/usr/lib/bing-wallpaper"
- install -d "$pkgdir/etc/xdg/autostart"
- cp bing-wallpaper.desktop "$pkgdir/etc/xdg/autostart"
+ install -m 755 bing-wallpaper-autostart.sh "${pkgdir}/usr/bin"
+ install -m 644 bing-wallpaper.desktop "$pkgdir/etc/xdg/autostart"
}
diff --git a/bing-wallpaper-autostart.sh b/bing-wallpaper-autostart.sh
index 4319b4a347bb..e1ea281511f6 100755
--- a/bing-wallpaper-autostart.sh
+++ b/bing-wallpaper-autostart.sh
@@ -3,11 +3,7 @@
# try 3 times only
i=1
while [ $i -le 3 ]; do
- if curl --connect-timeout 2 -s www.google.com > /dev/null ; then
- break
- fi
-
- if curl --connect-timeout 2 -s www.baidu.com > /dev/null ; then
+ if curl --connect-timeout 2 -s www.bing.com > /dev/null ; then
break
fi