summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2023-08-20 14:49:41 +0200
committerbartus2023-08-20 14:49:41 +0200
commit6a5bf1113801e98b88204b85110d83db4cf5841c (patch)
treeae159f3a387f6444873d1a40d6e917dde94afd28
parent24cb2996edc8e3f11d2a711249be58c685fb6a92 (diff)
downloadaur-6a5bf1113801e98b88204b85110d83db4cf5841c.tar.gz
Update cuda patch for the new folder structure
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--cuda11_gcc11.patch4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0556be30d12..003f02302f82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = General-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.7.r46.g0fed789f
+ pkgver = 3.8.r118.ga97b8461
pkgrel = 1
url = https://colmap.github.io/
arch = i686
@@ -33,7 +33,7 @@ pkgbase = colmap-git
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words256K.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin
sha256sums = SKIP
- sha256sums = 4b76da280b2c81ddb760e813d2c27c6b932790cc9aabaadbd0a917a6b57cfdfd
+ sha256sums = d98b4edeb142c7aaf056777955f8313458563439e15c4b659332189f5ea652aa
sha256sums = d37d8f19ee0a49705c4c0b06967a08cedfed5cf86519eada3271497256732bc2
sha256sums = d2055600452a531b5b0a62aa5943e1a07195273dc4eeebcf23d3a924d881d53a
sha256sums = fb60f7ba8081ee5c278f03c62329a374d1b24136b374a49393b453db1529a8c6
diff --git a/PKGBUILD b/PKGBUILD
index f17e2cd14f8f..d14951bebf06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _fragment=#${FRAGMENT:-branch=main}
_name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
pkgname=${_name}-git
-pkgver=3.8.r13.g2b1f843e
+pkgver=3.8.r118.ga97b8461
pkgrel=1
pkgdesc="General-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -31,7 +31,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${_fragment}"
"vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree_flickr100K_words1M.bin"
)
sha256sums=('SKIP'
- '4b76da280b2c81ddb760e813d2c27c6b932790cc9aabaadbd0a917a6b57cfdfd'
+ 'd98b4edeb142c7aaf056777955f8313458563439e15c4b659332189f5ea652aa'
'd37d8f19ee0a49705c4c0b06967a08cedfed5cf86519eada3271497256732bc2'
'd2055600452a531b5b0a62aa5943e1a07195273dc4eeebcf23d3a924d881d53a'
'fb60f7ba8081ee5c278f03c62329a374d1b24136b374a49393b453db1529a8c6')
diff --git a/cuda11_gcc11.patch b/cuda11_gcc11.patch
index f8eafd3f5e4a..9820e62376b9 100644
--- a/cuda11_gcc11.patch
+++ b/cuda11_gcc11.patch
@@ -1,7 +1,7 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3c60c055..bd76a7f7 100755
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
+--- a/src/colmap/CMakeLists.txt
++++ b/src/colmap/CMakeLists.txt
@@ -43,7 +43,7 @@ elseif(IS_GNU OR IS_CLANG)
IS_GNU AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 6)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")