summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-04 09:08:38 -0700
committerMark Wagie2024-03-04 09:08:38 -0700
commit6c30d8864005dd25db27bb0e4c8263e91e792b8d (patch)
treed3e59204e271b4d98a1b0477892d877f24eab7e8
parentdc93f121ed4242ef1f8898fe044ba10d74457a33 (diff)
downloadaur-6c30d8864005dd25db27bb0e4c8263e91e792b8d.tar.gz
4.6.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e887b3bf3f27..88e7548e90ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-cola
pkgdesc = The highly caffeinated Git GUI
- pkgver = 4.5.0
+ pkgver = 4.6.1
pkgrel = 1
url = https://git-cola.github.io
arch = any
@@ -18,6 +18,7 @@ pkgbase = git-cola
makedepends = rsync
depends = git
depends = hicolor-icon-theme
+ depends = python-importlib-metadata
depends = python-numpy
depends = python-polib
depends = python-pyqt5
@@ -26,9 +27,7 @@ pkgbase = git-cola
optdepends = python-pyinotify: file system change monitoring
optdepends = python-send2trash: enables "Send to Trash" functionality.
optdepends = tk: to use the built-in ssh-askpass handler
- source = git-cola-4.5.0.tar.gz::https://github.com/git-cola/git-cola/archive/v4.5.0.tar.gz
- source = 0001-Unvendorize-polib.py.patch
- sha256sums = f8baaf6e168d605bf087e6ef77137089d9f01ea13f7947bb31cc7ac58e5aa248
- sha256sums = ffeaafbf1495931d3ab5cee439a82bef340d9cb15d4d555a57e93aed47695fc9
+ source = git-cola-4.6.1.tar.gz::https://github.com/git-cola/git-cola/archive/v4.6.1.tar.gz
+ sha256sums = 665019bc23f794d4f9f796bb7ee8e666ed13c9c3a1848fe37fb3541a0a143a64
pkgname = git-cola
diff --git a/PKGBUILD b/PKGBUILD
index 241fe823271a..c591091a790f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
-pkgver=4.5.0
+pkgver=4.6.1
pkgrel=1
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
@@ -11,6 +11,7 @@ license=('GPL-2.0-or-later')
depends=(
'git'
'hicolor-icon-theme'
+ 'python-importlib-metadata'
'python-numpy'
'python-polib'
'python-pyqt5'
@@ -34,16 +35,13 @@ optdepends=(
'python-send2trash: enables "Send to Trash" functionality.'
'tk: to use the built-in ssh-askpass handler'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz"
- '0001-Unvendorize-polib.py.patch')
-sha256sums=('f8baaf6e168d605bf087e6ef77137089d9f01ea13f7947bb31cc7ac58e5aa248'
- 'ffeaafbf1495931d3ab5cee439a82bef340d9cb15d4d555a57e93aed47695fc9')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz")
+sha256sums=('665019bc23f794d4f9f796bb7ee8e666ed13c9c3a1848fe37fb3541a0a143a64')
prepare() {
cd "$pkgname-$pkgver"
# Remove vendorized polib.py
- patch -Np1 -i ../0001-Unvendorize-polib.py.patch
rm cola/polib.py
}