summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomasstorck2015-09-16 11:50:32 +0200
committertomasstorck2015-09-16 11:50:32 +0200
commit6d03d168f5b05e60564ee67ab9b756bce93e4edb (patch)
tree6f154d24e3c5026722232fc105186ae791075fac
parent2d32e49ba3e180846dc5f50f0d41098e2cd3f77e (diff)
downloadaur-6d03d168f5b05e60564ee67ab9b756bce93e4edb.tar.gz
Added vimdiff, which corresponds to nvim -d
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rwxr-xr-xvimdiff2
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95850c715277..9e4ef1d5ccdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovim-symlinks
pkgdesc = System-wide: Runs neovim if vi or vim is invoked.
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
arch = any
license = MIT
depends = neovim-git
diff --git a/PKGBUILD b/PKGBUILD
index d7ce8a19a7aa..c5585b789f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,21 @@ license=('MIT')
depends=('neovim-git')
provides=('vim' 'vi')
conflicts=('vim' 'vi' 'vi-vim-symlink')
-source=()
+source=('vimdiff')
+md5sums=('8ca45b6b93e6dab571f542ef262093e4')
sha256sums=()
package() {
install -dm755 "$pkgdir/usr/bin"
+ # vim --> nvim
_link_names=(edit ex rview rvim vedit vi view vim)
- for link in "${_link_names[@]}";
+ for _link in "${_link_names[@]}";
do
- ln -s nvim "$pkgdir/usr/bin/$link"
+ ln -s nvim "$pkgdir/usr/bin/$_link"
done
+
+ # vimdiff --> nvim -d
+ install -Dm755 "$srcdir/vimdiff" "$pkgdir/usr/bin/vimdiff"
}
diff --git a/vimdiff b/vimdiff
new file mode 100755
index 000000000000..5f69f228a5da
--- /dev/null
+++ b/vimdiff
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec vim -d "$@"