summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-06-25 00:03:04 +0200
committerPeter Jung2022-06-25 00:03:04 +0200
commit6f4907974ccd434035e98becdb55a33e54d9c53e (patch)
treed2c565c284e2927d03322d3b61a0965aee09b68d
parent6135a3f34418b2cb873d72f339398996d8ca773c (diff)
downloadaur-6f4907974ccd434035e98becdb55a33e54d9c53e.tar.gz
add system tbb back to makefile after arch patched tbb
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a349016b9db..381218552963 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mold-git
pkgdesc = A Modern Linker
- pkgver = v1.3.0_9_g9a3188bc
+ pkgver = v1.3.0_14_gd9a28221
pkgrel = 1
url = https://github.com/rui314/mold
arch = x86_64
@@ -11,8 +11,10 @@ pkgbase = mold-git
depends = mimalloc
depends = openssl
depends = zlib
- provides = mold=v1.3.0_9_g9a3188bc
+ depends = tbb
+ provides = mold=v1.3.0_14_gd9a28221
conflicts = mold
+ options = !debug
source = mold::git+https://github.com/rui314/mold
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f1cc265d207b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.zst
+*.tar.zst.sig
+mold/
diff --git a/PKGBUILD b/PKGBUILD
index ac6b0ff4b381..8df4100f4f11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Peter Jung ptr1337 <admin@ptr1337.dev>
pkgname=mold-git
-pkgver=v1.3.0_9_g9a3188bc
+pkgver=v1.3.0_14_gd9a28221
pkgrel=1
pkgdesc="A Modern Linker"
arch=(x86_64)
url="https://github.com/rui314/mold"
license=("AGPL3")
-# xxhash and tbb is bundled
-depends=('gcc-libs' 'mimalloc' 'openssl' 'zlib')
+# xxhash is bundled
+depends=('gcc-libs' 'mimalloc' 'openssl' 'zlib' 'tbb')
makedepends=('git' 'python')
source=("mold::git+https://github.com/rui314/mold")
sha256sums=('SKIP')
provides=("mold=$pkgver")
conflicts=("mold")
+options=('!debug')
reponame="mold"
pkgver() {
@@ -33,16 +34,18 @@ build() {
-C "$reponame" \
PREFIX=/usr \
LTO=1 \
- SYSTEM_MIMALLOC=1
+ SYSTEM_MIMALLOC=1 \
+ SYSTEM_TBB=1
}
check() {
- cd "$repname"
+ cd "$reponame"
make \
PREFIX=/usr \
LTO=1 \
SYSTEM_MIMALLOC=1 \
+ SYSTEM_TBB=1 \
check
}
@@ -52,6 +55,7 @@ package() {
PREFIX=/usr \
LTO=1 \
SYSTEM_MIMALLOC=1 \
+ SYSTEM_TBB=1 \
DESTDIR="$pkgdir" \
install
}