summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor2021-03-19 12:23:46 +0100
committerVictor2021-03-19 12:23:46 +0100
commit6f9d982971cc83a9ffd826d49cb30f480c240c4f (patch)
treefe34b8545d7256fa08b01df5d1d8418dbd007192
parent796936764f8a81e6437b682d66032ac3ac694835 (diff)
downloadaur-6f9d982971cc83a9ffd826d49cb30f480c240c4f.tar.gz
Update to 1.12.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a981793e465c..ba47e21ba533 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thrust
pkgdesc = A C++ parallel programming library which resembles the C++ Standard Library
- pkgver = 1.11.0
+ pkgver = 1.12.0
pkgrel = 1
url = https://github.com/thrust/thrust
arch = any
@@ -8,10 +8,10 @@ pkgbase = thrust
optdepends = cuda: for CUDA backend
optdepends = openmp: for OMP backend
optdepends = intel-tbb: for TBB backend
- source = thrust-1.11.0.tar.gz::https://github.com/thrust/thrust/archive/1.11.0.tar.gz
- source = cub-1.11.0.tar.gz::https://github.com/thrust/cub/archive/1.11.0.tar.gz
- sha256sums = c65211a66fe0dce9f5470cc8fcb80ae6b04da12fd94707ed63ddddbd82fa9444
- sha256sums = 58948cfd0d46ed5ff683b5337a5de43d3c46a922f55404c32d09a6375b4f3108
+ source = thrust-1.12.0.tar.gz::https://github.com/thrust/thrust/archive/1.12.0.tar.gz
+ source = cub-1.12.0.tar.gz::https://github.com/thrust/cub/archive/1.12.0.tar.gz
+ sha256sums = d68f89937ed1a0dadafd4f77d3e65ab9a5baa48dd5fa5698f8d3f7e3d6749da2
+ sha256sums = 3b03d0cbc9549606fbeda69a920562eb563836346b39014c79dfd024165ee549
pkgname = thrust
diff --git a/PKGBUILD b/PKGBUILD
index 434656ccb71e..40fa18c62a61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Xiang Gao <qasdfgtyuiop@gmail.com>
pkgname=thrust
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=1
pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library'
arch=('any')
@@ -17,8 +17,8 @@ optdepends=(
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz"
"cub-${pkgver}.tar.gz::https://github.com/thrust/cub/archive/${pkgver}.tar.gz")
-sha256sums=('c65211a66fe0dce9f5470cc8fcb80ae6b04da12fd94707ed63ddddbd82fa9444'
- '58948cfd0d46ed5ff683b5337a5de43d3c46a922f55404c32d09a6375b4f3108')
+sha256sums=('d68f89937ed1a0dadafd4f77d3e65ab9a5baa48dd5fa5698f8d3f7e3d6749da2'
+ '3b03d0cbc9549606fbeda69a920562eb563836346b39014c79dfd024165ee549')
package() {
install -dm 755 "${pkgdir}/opt/${pkgname}"