summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkageru2020-06-23 10:37:28 +0200
committerkageru2020-06-23 10:37:28 +0200
commit70a27e8037ff084e3b4efaae389f4c12f9b21d54 (patch)
tree0625f0bb5d78b174e70c3be5b63fcf861b27ab42
parent7b69962107e38283a1a46a0777c2395620d88bca (diff)
downloadaur-70a27e8037ff084e3b4efaae389f4c12f9b21d54.tar.gz
Fix filename in config patch
Looks like gitea renamed it from sample to example for <reasons>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--gitea-arch-defaults.patch19
3 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e74c45577480..87834b913bbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitea-git
pkgdesc = Painless self-hosted Git service. Community managed fork of Gogs.
- pkgver = v1.13.0_dev_174_gb682a2c1b
+ pkgver = v1.13.0_dev_234_gd9aa007a9
pkgrel = 1
url = https://gitea.io/
install = gitea.install
@@ -33,7 +33,7 @@ pkgbase = gitea-git
sha512sums = 89bf119a91fd48ed35c06131c67de1b4300bd2e79522c47aee9a73d7f1ebb08d9bceadc37408bd2425475d92c8bf59d87a799f2ce0a46bee860bf9fc7a904103
sha512sums = 0b93ddbb88ff843014f583a36c00156c011cca568cb69b61eb4c576c557b21ecdab1b105815a5dfdd08349e4e3b0976c8bdf87c8d3b201edae95de9070200352
sha512sums = 77f672ed82bc8f78ca04b1e2b7c7d026cb897da6e4f057817adbe1242bf8a67875061553806e6b027cdb3266cdf217ee3993efd9242a66c5802ed34344b5ded1
- sha512sums = fc415c8284e23bc6cbb440713d4d1165a3c3159fb1f3ebf80ffc9a016c02c4415ec532e3ed4f34667e3b53ab474e34e69289cfc275bf666ae0135b5310e90de1
+ sha512sums = a91acf8b8627b29ebc23ae5dfc7a26d62e5dc8443dcc47e2f13d2290b2c2bc96ebddcc83419aa571ed5890304dfc15a82ebec771b05e3c9c6900b48d855d6cc7
pkgname = gitea-git
diff --git a/PKGBUILD b/PKGBUILD
index b75f56b48020..e0b08d44d198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname='gitea'
pkgname=gitea-git
-pkgver=v1.13.0_dev_174_gb682a2c1b
+pkgver=v1.13.0_dev_234_gd9aa007a9
pkgrel=1
pkgdesc='Painless self-hosted Git service. Community managed fork of Gogs.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -36,7 +36,7 @@ sha512sums=('SKIP'
'89bf119a91fd48ed35c06131c67de1b4300bd2e79522c47aee9a73d7f1ebb08d9bceadc37408bd2425475d92c8bf59d87a799f2ce0a46bee860bf9fc7a904103'
'0b93ddbb88ff843014f583a36c00156c011cca568cb69b61eb4c576c557b21ecdab1b105815a5dfdd08349e4e3b0976c8bdf87c8d3b201edae95de9070200352'
'77f672ed82bc8f78ca04b1e2b7c7d026cb897da6e4f057817adbe1242bf8a67875061553806e6b027cdb3266cdf217ee3993efd9242a66c5802ed34344b5ded1'
- 'fc415c8284e23bc6cbb440713d4d1165a3c3159fb1f3ebf80ffc9a016c02c4415ec532e3ed4f34667e3b53ab474e34e69289cfc275bf666ae0135b5310e90de1')
+ 'a91acf8b8627b29ebc23ae5dfc7a26d62e5dc8443dcc47e2f13d2290b2c2bc96ebddcc83419aa571ed5890304dfc15a82ebec771b05e3c9c6900b48d855d6cc7')
install=gitea.install
pkgver() {
@@ -74,7 +74,7 @@ package() {
install -Dm644 ${_pkgname}.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm644 ${_pkgname}.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/${_pkgname}.conf
install -Dm644 ${_pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${_pkgname}.conf
- install -D ${_pkgname}/custom/conf/app.ini.sample "${pkgdir}"/etc/gitea/app.ini
+ install -D ${_pkgname}/custom/conf/app.example.ini "${pkgdir}"/etc/gitea/app.ini
}
# vim: ts=2 sw=2 et:
diff --git a/gitea-arch-defaults.patch b/gitea-arch-defaults.patch
index 94521992ab86..6cc4248e6ac1 100644
--- a/gitea-arch-defaults.patch
+++ b/gitea-arch-defaults.patch
@@ -1,6 +1,6 @@
---- a/custom/conf/app.ini.sample
-+++ b/custom/conf/app.ini.sample
-@@ -8,12 +8,12 @@
+--- a/custom/conf/app.example.ini
++++ b/custom/conf/app.example.ini
+@@ -7,12 +7,12 @@
; App name that shows in every page title
APP_NAME = Gitea: Git with a cup of tea
; Change it if you run locally
@@ -14,9 +14,9 @@
-ROOT =
+ROOT = /var/lib/gitea/repos
SCRIPT_TYPE = bash
- ; Default ANSI charset
- ANSI_CHARSET =
-@@ -280,7 +280,7 @@ CERT_FILE = https/cert.pem
+ ; DETECTED_CHARSETS_ORDER tie-break order for detected charsets.
+ ; If the charsets have equal confidence, tie-breaking will be done by order in this list
+@@ -315,7 +315,7 @@
KEY_FILE = https/key.pem
; Root directory containing templates and static files.
; default is the path where Gitea is executed
@@ -25,8 +25,7 @@
; Default path for App data
APP_DATA_PATH = data
; Application level GZIP support
-
-@@ -341,7 +341,7 @@
+@@ -385,7 +385,7 @@
; For iterate buffer, default is 50
ITERATE_BUFFER_SIZE = 50
; Show the database generated SQL
@@ -35,7 +34,7 @@
; Maximum number of DB Connect retries
DB_RETRIES = 10
; Backoff time per DB retry (time.Duration)
-@@ -696,10 +696,10 @@
+@@ -761,10 +761,10 @@
DEFAULT_UI_LOCATION =
[log]
@@ -48,7 +47,7 @@
; Buffer length of the channel, keep it as it is if you don't know what it is.
BUFFER_LEN = 10000
REDIRECT_MACARON_LOG = false
-@@ -724,7 +724,7 @@
+@@ -789,7 +789,7 @@
; For "console" mode only
[log.console]