summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2023-05-25 13:31:15 +0200
committerZacharias Knudsen2023-05-25 13:31:15 +0200
commit71ad260f90ee9d70b97a45b16a5f13618e4dc60e (patch)
tree16afe999faa0cfff84bc08b37fab15b74a49cb9d
parent3e2b4a07eb9acde85e7ee0c07a6cdcd48deb199f (diff)
downloadaur-71ad260f90ee9d70b97a45b16a5f13618e4dc60e.tar.gz
Fix desktop entry
-rw-r--r--PKGBUILD16
-rw-r--r--gog-unreal-tournament-goty.desktop8
2 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b26c46f98dc..18f921a44098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=gog-unreal-tournament-goty
pkgver=469c
-pkgrel=3
+pkgrel=4
pkgdesc="Unreal Tournament (99): Game of the Year Edition. GOG Version."
arch=('x86_64')
-url="https://www.gog.com/game/unreal_tournament_goty"
+url="https://www.gog.com/forum/general/delisting_unreal_games_unreal_tournament_2004_ut_goty_unreal_2_the_awakening_special_edition/post1"
# https://github.com/OldUnreal/UnrealTournamentPatches/blob/master/LICENSE.md
license=('MIT' 'BSD' 'ZLIB' 'GPL2' 'LGPL2.1' 'ZLIB' 'OFL' 'Apache' 'custom')
depends=('mpg123' 'openal' 'sdl2' 'libxmp')
-makedepends=('innoextract')
+makedepends=('innoextract' 'imagemagick')
source=("setup_ut_goty.exe::gogdownloader://unreal_tournament_goty/en1installer0"
"patch-${pkgver}.tar.bz2::https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469c/OldUnreal-UTPatch469c-Linux-amd64.tar.bz2"
"gog-unreal-tournament-goty.desktop"
@@ -16,7 +16,7 @@ source=("setup_ut_goty.exe::gogdownloader://unreal_tournament_goty/en1installer0
noextract=("patch-${pkgver}.tar.bz2")
sha256sums=("4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803"
"4c99bde06d26b724f14471d374d4d6105dbdc98c56ec2a40af3fa541956eeed9"
- "4c507f98e74b3f6aa87cc1d8e48750afd4f0b33078337d5406efd0e46d256600"
+ "2d40b8b7ea8434e11e27db9c07c0c8fb3aab28013fd3d80a6425e506ef2433ed"
"518a904603b3971eb516d0c5198031345dd2d3b5e6d87d12e02dccfe169a9505")
# If you want to use lgogdownloader add the following to /etc/makepkg.conf
@@ -52,6 +52,9 @@ prepare() {
# create an "addons/" folder next to the PKGBUILD.
# Whatever is in there will get copied to the root of the game's directory.
cp --archive ${startdir}/addons/* "unreal" 2>/dev/null || true # allow no `addons/` folder
+
+ # Convert icon
+ convert "app/gfw_high.ico" "icon.png"
}
package() {
@@ -71,11 +74,14 @@ package() {
"/opt/gog/${pkgname#gog-}/System64/ut-bin-amd64" \
"${pkgdir}/usr/bin/${pkgname}"
- # install desktop entry and license document
+ # install desktop entry, icon and license document
install -D --mode 644 \
"${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D --mode 644 \
+ "icon-5.png" \
+ "${pkgdir}/usr/share/icons/${pkgname}.png"
+ install -D --mode 644 \
"unreal/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/gog-unreal-tournament-goty.desktop b/gog-unreal-tournament-goty.desktop
index 800c998a49b9..859776a79526 100644
--- a/gog-unreal-tournament-goty.desktop
+++ b/gog-unreal-tournament-goty.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=UT99
-Exec=/opt/gog/unreal-tournament-goty/System/ut-bin-amd64
+Type=Application
+Name=Unreal Tournament GOTY
Comment=Unreal Tournament (99): Game of the Year Edition. GOG Version.
+Exec=/usr/bin/gog-unreal-tournament-goty
+Icon=gog-unreal-tournament-goty
Terminal=false
-Icon=/opt/gog/unreal-tournament-goty/System/Unreal.ico
-Type=Application
Categories=Game;