summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry Chen2018-08-09 10:23:53 +0800
committerHarry Chen2018-08-09 10:23:53 +0800
commit735b20e361e9428ff7272f079d95f5c7397d2e06 (patch)
treed6f1355f18f81a695f3cb70a592912b305caf420
parentbe6f0ee17200dbcf76f907493eed5269589f5fdd (diff)
downloadaur-735b20e361e9428ff7272f079d95f5c7397d2e06.tar.gz
Upgrade gcc to 8.2.0 and remove redundant dependencies
Signed-off-by: Harry Chen <i@harrychen.xyz>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7de645b61c4..a1ed34cf35ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = cross-mipsel-linux-gnu-gcc
pkgdesc = The GNU Compiler Collection for the MIPS architecture
- pkgver = 8.1.0
+ pkgver = 8.2.0
pkgrel = 1
url = https://www.gnu.org/software/gcc/
arch = x86_64
license = GPL
license = LGPL
license = FDL
- makedepends = gcc
- makedepends = make
makedepends = gmp
makedepends = mpfr
depends = libmpc
- depends = sh
depends = xz
depends = cross-mipsel-linux-gnu-binutils
options = !ccache
@@ -20,8 +17,8 @@ pkgbase = cross-mipsel-linux-gnu-gcc
options = !emptydirs
options = !libtool
options = !strip
- source = ftp://ftp.gnu.org/gnu/gcc/gcc-8.1.0/gcc-8.1.0.tar.xz
- md5sums = 65f7c65818dc540b3437605026d329fc
+ source = ftp://ftp.gnu.org/gnu/gcc/gcc-8.2.0/gcc-8.2.0.tar.xz
+ md5sums = 4ab282f414676496483b3e1793d07862
pkgname = cross-mipsel-linux-gnu-gcc
diff --git a/PKGBUILD b/PKGBUILD
index d4d1f05c280d..cc44df7e9b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
pkgname=cross-mipsel-linux-gnu-gcc
_pkgname=gcc
_target="mipsel-linux-gnu"
-pkgver=8.1.0
+pkgver=8.2.0
pkgrel=1
pkgdesc="The GNU Compiler Collection for the MIPS architecture"
url="https://www.gnu.org/software/gcc/"
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
-depends=('libmpc' 'sh' 'xz' "cross-${_target}-binutils")
-makedepends=('gcc' 'make' 'gmp' 'mpfr')
+depends=('libmpc' 'xz' "cross-${_target}-binutils")
+makedepends=('gmp' 'mpfr')
options=('!ccache' '!distcc' '!emptydirs' '!libtool' '!strip')
source=("ftp://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/${_pkgname}-${pkgver}.tar.xz")
-md5sums=('65f7c65818dc540b3437605026d329fc')
+md5sums=('4ab282f414676496483b3e1793d07862')
_sysroot="/usr/lib/cross-${_target}"
prepare() {