summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2020-05-18 12:55:04 -0400
committerMatthew McGinn2020-05-18 12:56:34 -0400
commit73e1301dbe953be0bbbfa4f58dc03810860fb843 (patch)
tree641d93568c7ec73b5926ac96cdfbc6c03b0e53cd
parent1036207297b318461ef2b5ebe890bc2b02499e53 (diff)
downloadaur-73e1301dbe953be0bbbfa4f58dc03810860fb843.tar.gz
bump to 1.46.0
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--bind.patch11
3 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d19e4c4fda..0c7817726110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = bitbake
pkgdesc = Build tool executing tasks and managing metadata.
- pkgver = 1.44.1
+ pkgver = 1.46.0
pkgrel = 1
url = https://www.openembedded.org/wiki/Main_Page
arch = any
license = GPL2
makedepends = git
makedepends = wget
- source = https://github.com/openembedded/bitbake/archive/1.44.1.tar.gz
- md5sums = f1738e17e75c71166fb9f4ef7367ae51
+ source = https://github.com/openembedded/bitbake/archive/1.46.0.tar.gz
+ source = bind.patch
+ md5sums = aff0217dcba08df3dcbbad256cc07911
+ md5sums = 44506db845c085dc8916a05ca4348947
pkgname = bitbake
install = bitbake.install
diff --git a/PKGBUILD b/PKGBUILD
index 9e33232f7ac7..04660f4bee15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,18 @@
pkgbase=bitbake
pkgname=('bitbake' 'bitbake-vim')
_github_url="https://github.com/openembedded/bitbake"
-pkgver=1.44.1
+pkgver=1.46.0
pkgrel=1
pkgdesc='Build tool executing tasks and managing metadata.'
arch=('any')
url='https://www.openembedded.org/wiki/Main_Page'
license=('GPL2')
makedepends=('git' 'wget')
-source=("https://github.com/openembedded/bitbake/archive/${pkgver}.tar.gz")
-md5sums=('f1738e17e75c71166fb9f4ef7367ae51')
+source=("https://github.com/openembedded/bitbake/archive/${pkgver}.tar.gz"
+ "bind.patch"
+ )
+md5sums=('aff0217dcba08df3dcbbad256cc07911'
+ '44506db845c085dc8916a05ca4348947')
check() {
if ! git config --global --get user.name; then
@@ -26,9 +29,8 @@ check() {
git config --global user.email "test@bitbake.com"
fi
# use http over ftp to use travis
- # grep -rl "[^s]ftp://" "${pkgname}-${pkgver}"/lib/bb/tests/*py | xargs sed -i 's@ftp://@http://@g'
- # git config --local -l
cd "${pkgbase}-${pkgver}"
+ patch -p0 < "${srcdir}/bind.patch"
BB_SKIP_NETTESTS='yes' PYTHONPATH="${srcdir}/${pkgbase}-${pkgver}/lib" PATH="${PATH}:${srcdir}/${pkgbase}-${pkgver}/bin" python ./bin/bitbake-selftest --failfast -v
if [ "${unset_name}" -eq 1 ]; then
unset_name=1
diff --git a/bind.patch b/bind.patch
new file mode 100644
index 000000000000..3d1d9174d831
--- /dev/null
+++ b/bind.patch
@@ -0,0 +1,11 @@
+--- bin/bitbake-prserv 2020-05-11 10:39:29.778714233 -0400
++++ bin/bitbake-prserv 2020-05-11 10:39:48.698497166 -0400
+@@ -14,7 +14,7 @@
+
+ __version__="1.0.0"
+
+-PRHOST_DEFAULT='0.0.0.0'
++PRHOST_DEFAULT='127.0.0.1'
+ PRPORT_DEFAULT=8585
+
+ def main():