aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVufa2023-03-06 16:24:47 +0800
committerVufa2023-03-06 16:24:47 +0800
commit7543c61e5cb69ce6598df85a8bce58b518a90a80 (patch)
tree679c99abd23542cfd55ab5e1a667761a71f85451
parent793ade76f652567b06551178424f3a45cc908dbd (diff)
downloadaur-7543c61e5cb69ce6598df85a8bce58b518a90a80.tar.gz
forbid wechat browser creating crash logs
Signed-off-by: Vufa <countstarlight@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--README.md12
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebbeded5afb9..942264b52eab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deepin-wine-wechat
pkgdesc = Tencent WeChat on Deepin Wine(com.qq.weixin.deepin) For Archlinux
pkgver = 3.9.0.28
- pkgrel = 2
+ pkgrel = 3
url = https://weixin.qq.com/
install = deepin-wine-wechat.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 30db576ee0d7..59a5572e754f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=3.9.0.28
wechat_installer=WeChatSetup
deepinwechatver=3.4.0.38deepin6
debpkgname="com.qq.weixin.deepin"
-pkgrel=2
+pkgrel=3
pkgdesc="Tencent WeChat on Deepin Wine(${debpkgname}) For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
@@ -57,9 +57,9 @@ build() {
msg "Copying mmmojo.dll and mmmojo_64.dll to ${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/ ..."
install -m644 "${srcdir}/mmmojo.dll" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
install -m644 "${srcdir}/mmmojo_64.dll" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
- #msg "Creating 'XPlugin/Plugins/XWeb' to forbid wechat browser creating crash logs ..."
- #mkdir -p "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/"
- #touch "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/XWeb"
+ msg "Creating 'XPlugin/Plugins/XWeb' to forbid wechat browser creating crash logs ..."
+ mkdir -p "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/"
+ touch "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/XWeb"
#find -L "${srcdir}/deepinwechatdir/dosdevices" -maxdepth 1 -type l -delete
msg "Repackaging app archive ..."
7z a -t7z -r "${srcdir}/files.7z" "${srcdir}/deepinwechatdir/*"
diff --git a/README.md b/README.md
index 77c5d76b0200..9ce2f32476c7 100644
--- a/README.md
+++ b/README.md
@@ -40,8 +40,8 @@ Deepin 打包的微信容器(`com.qq.weixin.deepin`)移植到 Archlinux,包含
- [GNOME 桌面上的托盘图标](#gnome-桌面上的托盘图标)
- [消除阴影边框](#消除阴影边框)
- [唤出已运行的 WeChat 窗口](#唤出已运行的-wechat-窗口)
- - [旧方法:](#旧方法)
- - [新方法:](#新方法)
+ - [方法1](#方法1)
+ - [方法2](#方法2)
- [感谢](#感谢)
- [更新日志](#更新日志)
@@ -132,7 +132,7 @@ dpi,系统版本,目录映射等可以在 `winecfg` 进行设置,打开 `w
| 微信版本 | wine | 兼容性 | 备注 | deepin-wine | 兼容性 | 备注 |
| :-----------------: | :-------: | :--------: | :----------------------------------------------------------: | :---------: | :----: | :----------------------------------------------------------: |
-| 3.9.0.28-2~ | \ | \ | \ | 6.0.0.42-1 | 部分 | 截图不可用 |
+| 3.9.0.28-2~ | \ | \ | \ | 6.0.0.42-1 | 部分 | 截图不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
| 3.8.0.41~3.8.1.26 | \ | \ | \ | 6.0.0.39-1 | 部分 | 截图不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
| 3.7.0.30~3.7.6.44 | \ | \ | \ | 6.0.0.24-1 | 部分 | 截图和表情包不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
| 3.5.0.46~3.7.0.30 | \ | \ | \ | 6.0.0.24-1 | 部分 | 小程序和公众号可用,截图([#192](https://github.com/vufa/deepin-wine-wechat-arch/issues/192))和表情包不可用([#177](https://github.com/vufa/deepin-wine-wechat-arch/issues/188)) |
@@ -241,7 +241,7 @@ DEEPIN_WINE_SCALE=1.25
### 唤出已运行的 WeChat 窗口
-#### 旧方法:
+#### 方法1
运行命令:
@@ -251,7 +251,9 @@ DEEPIN_WINE_SCALE=1.25
可以参考 [deepin-wine-wechat-arch#96](https://github.com/vufa/deepin-wine-wechat-arch/issues/96) 和 [deepin-wine-wechat-arch#263](https://github.com/vufa/deepin-wine-wechat-arch/issues/263) 将该命令存入脚本并添加到全局快捷键中,方便使用
-#### 新方法:
+#### 方法2
+
+> 由 [thep0y](https://github.com/thep0y) 提供
点击图标时如果已有正在运行的实例会导致错误的 kill,原因是`/opt/deepinwine/tools/kill.sh`中: