summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortohmais2023-03-06 08:54:31 +1000
committertohmais2023-03-06 08:54:31 +1000
commit757614af7729352fda534abe9eb1a88fe77dfe04 (patch)
tree35a4ade4e43ea82d6f33e1d998eec2cc9abb4de4
parent0bfc5ba8d42f29eccd2d3119e06a32b4ff840492 (diff)
downloadaur-757614af7729352fda534abe9eb1a88fe77dfe04.tar.gz
update patch command for custom builddirs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c5bf1d0c391..7b7262bc224a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nvidia-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)
- pkgver = r2551.c4440993
+ pkgver = r2568.7739b776
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index f069296affed..396f1f6b369d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia-git"
-pkgver=r2551.c4440993
+pkgver=r2568.7739b776
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -70,7 +70,7 @@ build() {
git submodule update --init
make fixwlr
patch --directory="$srcdir/$_pkgname/subprojects/wlroots/" --forward --strip=0 \
- --input="${srcdir}/../nvidia.patch"
+ --input="${srcdir}/nvidia.patch"
cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../
cd udis86 && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(shell nproc) && cd ../..
make protocols