summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-12-08 21:19:26 +0100
committerNicola Murino2019-12-08 21:19:26 +0100
commit787b3df407aeec6255bebf59960881312039db9c (patch)
treeae03b7752adb2179dbd58ac08df49a92319ba7d2
parentdd344c749391da36d80b58ee17b6b123f9169468 (diff)
downloadaur-787b3df407aeec6255bebf59960881312039db9c.tar.gz
add sys_root to the cross file and install meson-cross-file-generator
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rwxr-xr-xtoolchain_generator.py3
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f67df1e0367c..b27c032fcc39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-meson
pkgdesc = Meson wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 17
+ pkgrel = 18
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
@@ -13,7 +13,7 @@ pkgbase = mingw-w64-meson
optdepends = mingw-w64-cmake
source = toolchain_generator.py
source = meson-mingw-wrapper
- sha256sums = e7635c6cbb1c4c99fc41910083febfb3d0f7d4b6995537a2fb7ab55322ee2910
+ sha256sums = eccc039b3d46cc6ed3f48d526c9434a28da80caa88d0d7240866ab7d0370d164
sha256sums = c91f2bbcafad7b742f13c6bd46324a03b70066b348621ce6a20f4a05005985ef
pkgname = mingw-w64-meson
diff --git a/PKGBUILD b/PKGBUILD
index a430f423f04c..03b93058dd47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-meson
pkgver=1
-pkgrel=17
+pkgrel=18
arch=('any')
pkgdesc="Meson wrapper for MinGW (mingw-w64)"
depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
@@ -12,7 +12,7 @@ license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("toolchain_generator.py"
"meson-mingw-wrapper")
-sha256sums=('e7635c6cbb1c4c99fc41910083febfb3d0f7d4b6995537a2fb7ab55322ee2910'
+sha256sums=('eccc039b3d46cc6ed3f48d526c9434a28da80caa88d0d7240866ab7d0370d164'
'c91f2bbcafad7b742f13c6bd46324a03b70066b348621ce6a20f4a05005985ef')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -32,6 +32,7 @@ build() {
package() {
install -d "${pkgdir}"/usr/bin
install -d "${pkgdir}"/usr/share/mingw
+ install -m 755 "${srcdir}/toolchain_generator.py" "$pkgdir/usr/bin/meson-cross-file-generator"
for _arch in ${_architectures}; do
install -m 755 "${srcdir}/${_arch}-meson" "$pkgdir/usr/bin/${_arch}-meson"
install -m 644 toolchain-${_arch}.meson "${pkgdir}"/usr/share/mingw/
diff --git a/toolchain_generator.py b/toolchain_generator.py
index 0ef4e5e9dab0..75e8e34539b3 100755
--- a/toolchain_generator.py
+++ b/toolchain_generator.py
@@ -45,6 +45,7 @@ class CrossFileGenerator:
def get_properties_section(self):
return {'root':"'{}'".format(self.arch),
+ 'sys_root':"'/usr/{}'".format(self.arch),
'c_args':[f for f in self.cflags.split(" ") if f],
'cpp_args':[f for f in self.cxxflags.split(" ") if f],
'c_link_args':[f for f in self.ldflags.split(" ") if f],
@@ -70,7 +71,7 @@ if __name__ == '__main__':
required.add_argument('--output-file', type=str, required=True, help='Write the generated cross file to this path')
optional.add_argument('-h', '--help', action='help', default=argparse.SUPPRESS,
help='show this help message and exit')
- optional.add_argument("--need-exe-wrapper", dest='need_exe_wrapper', action='store_true', help="Add wine as exec wrapper")
+ optional.add_argument("--need-exe-wrapper", dest='need_exe_wrapper', action='store_true', help="Add wine as exe wrapper")
args = parser.parse_args()
generator = CrossFileGenerator(args.arch, args.output_file, args.need_exe_wrapper)
generator.generate()