summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2020-10-15 02:20:50 -0400
committerskydrome2020-10-15 02:20:50 -0400
commit7addd7c9f878fc8f056e7b757cad560a370d17d7 (patch)
treed01af8a682333599b0782ef2738736a317816355
parent8d61d7c302efe29aee503fd65d788185ed8e762d (diff)
downloadaur-7addd7c9f878fc8f056e7b757cad560a370d17d7.tar.gz
1487
-rw-r--r--.SRCINFO15
-rw-r--r--0001-keyutils-fix-constructor-call.patch58
-rw-r--r--PKGBUILD36
-rw-r--r--freenet.ini.dist (renamed from freenet.ini)0
-rw-r--r--freenet.install8
5 files changed, 14 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb24b61b6ace..cf3a1e8c8a33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freenet
pkgdesc = A peer-to-peer platform for censorship-resistant communication and publishing
- pkgver = 0.7.5.1486
+ pkgver = 0.7.5.1487
pkgrel = 1
url = https://freenetproject.org
install = freenet.install
@@ -16,34 +16,25 @@ pkgbase = freenet
depends = nss
depends = java-service-wrapper
backup = opt/freenet/wrapper.config
- backup = opt/freenet/conf/freenet.ini
- source = git+https://github.com/freenet/fred.git?signed#tag=build01486
- source = git+https://github.com/freenet/plugin-KeyUtils.git#tag=v5026
- source = git+https://github.com/freenet/plugin-UPnP.git#tag=10007
- source = git+https://github.com/redwerk/plugin-Library.git#branch=frn-97-4
+ source = git+https://github.com/freenet/fred.git?signed#tag=build01487
source = git+https://github.com/xor-freenet/plugin-WebOfTrust.git#branch=next
source = git+https://github.com/freenet/seedrefs.git
source = IpToCountry.dat::http://software77.net/geo-ip/?DL=4
source = run.sh
source = wrapper.config
- source = freenet.ini
+ source = freenet.ini.dist
source = freenet.service
source = freenet.tmpfiles
- source = 0001-keyutils-fix-constructor-call.patch
validpgpkeys = B30C3D91069F81ECFEFED0B1B41A6047FD6C57F9
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = c56b3427ce3df2a9126acf737107738dffeab54d618887743c45a317d39a1b10
sha256sums = 9c8a99f7644859f37242465c2646f819c9458c4c0fe8d930db32837ddb2c6daf
sha256sums = 1171d0545882e45e03531e760fd28024700bf50400a3e3a13f31deeace8dbb03
sha256sums = 10f97306ef75953f20978d3d2aa5d14daa8fa13e4db88e8270ea951239212c20
sha256sums = 8f35e9d7d00e4caa26d0c1cbcbcedc9081ed0535d0c67e3f9d2d75c11ff9e847
- sha256sums = 0211a8778328805db1c9ed6991203c5bb097d00cfb7112a9c7db53df0b2bfb3c
pkgname = freenet
diff --git a/0001-keyutils-fix-constructor-call.patch b/0001-keyutils-fix-constructor-call.patch
deleted file mode 100644
index 207184fb09da..000000000000
--- a/0001-keyutils-fix-constructor-call.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 1b4899895442c368707035ea6b3bf9205beb08fe Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?David=20=E2=80=98Bombe=E2=80=99=20Roden?=
- <bombe@pterodactylus.net>
-Date: Tue, 11 Aug 2020 09:56:07 +0200
-Subject: [PATCH] Fix constructor call
-
----
- src/plugins/KeyUtils/VerySimpleGetter.java | 23 +---------------------
- 1 file changed, 1 insertion(+), 22 deletions(-)
-
-diff --git a/src/plugins/KeyUtils/VerySimpleGetter.java b/src/plugins/KeyUtils/VerySimpleGetter.java
-index 7eec25c..7e691cf 100644
---- a/src/plugins/KeyUtils/VerySimpleGetter.java
-+++ b/src/plugins/KeyUtils/VerySimpleGetter.java
-@@ -10,7 +10,6 @@
- import freenet.keys.FreenetURI;
- import freenet.node.RequestClient;
- import freenet.support.Logger;
--import freenet.support.io.ResumeFailedException;
-
- /**
- * @author saces
-@@ -25,26 +24,6 @@
- }
-
- private FreenetURI uri;
--
-- private static class FakeCallback implements ClientBaseCallback {
--
-- FakeCallback(RequestClient client) {
-- this.client = client;
-- }
--
-- final RequestClient client;
--
-- @Override
-- public void onResume(ClientContext context) throws ResumeFailedException {
-- throw new UnsupportedOperationException();
-- }
--
-- @Override
-- public RequestClient getRequestClient() {
-- return client;
-- }
--
-- }
-
- /**
- * @param priorityclass
-@@ -54,7 +33,7 @@ public RequestClient getRequestClient() {
- *
- */
- public VerySimpleGetter(short priorityclass, FreenetURI uri2, RequestClient client2) {
-- super(priorityclass, new FakeCallback(client2));
-+ super(priorityclass, client2);
- uri = uri2;
- }
-
diff --git a/PKGBUILD b/PKGBUILD
index 0b2e6773618d..fbf735c0f6ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
# Maintainer: skydrome <skydrome at@at proton mail dot com>
# Contributors: Thynix
-_fred=build01486
+_fred=build01487
_wot=next
-_keyutils=v5026
-_upnp=10007
-_library=frn-97-4
-_plugins=('WebOfTrust' 'UPnP' 'KeyUtils' 'Library')
+_plugins=('WebOfTrust')
pkgname=freenet
-pkgver=0.7.5.1486
+pkgver=0.7.5.1487
pkgrel=1
pkgdesc="A peer-to-peer platform for censorship-resistant communication and publishing"
url="https://freenetproject.org"
@@ -19,36 +16,26 @@ arch=('i686' 'x86_64')
install='freenet.install'
depends=('java-runtime>=8' 'gmp' 'nss' 'java-service-wrapper')
makedepends=('java-environment>=8' 'ant' 'git' 'zip')
-backup=('opt/freenet/wrapper.config'
- 'opt/freenet/conf/freenet.ini')
+backup=('opt/freenet/wrapper.config')
# https://freenetproject.org/assets/keyring.gpg
validpgpkeys=('B30C3D91069F81ECFEFED0B1B41A6047FD6C57F9')
source=("git+https://github.com/freenet/fred.git?signed#tag=$_fred"
- "git+https://github.com/freenet/plugin-KeyUtils.git#tag=$_keyutils"
- "git+https://github.com/freenet/plugin-UPnP.git#tag=$_upnp"
- "git+https://github.com/redwerk/plugin-Library.git#branch=$_library"
"git+https://github.com/xor-freenet/plugin-WebOfTrust.git#branch=$_wot"
"git+https://github.com/freenet/seedrefs.git"
"IpToCountry.dat::http://software77.net/geo-ip/?DL=4"
- 'run.sh' 'wrapper.config' freenet.{ini,service,tmpfiles}
- '0001-keyutils-fix-constructor-call.patch'
-)
+ 'run.sh' 'wrapper.config' freenet.{ini.dist,service,tmpfiles})
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'c56b3427ce3df2a9126acf737107738dffeab54d618887743c45a317d39a1b10'
'9c8a99f7644859f37242465c2646f819c9458c4c0fe8d930db32837ddb2c6daf'
'1171d0545882e45e03531e760fd28024700bf50400a3e3a13f31deeace8dbb03'
'10f97306ef75953f20978d3d2aa5d14daa8fa13e4db88e8270ea951239212c20'
- '8f35e9d7d00e4caa26d0c1cbcbcedc9081ed0535d0c67e3f9d2d75c11ff9e847'
- '0211a8778328805db1c9ed6991203c5bb097d00cfb7112a9c7db53df0b2bfb3c')
+ '8f35e9d7d00e4caa26d0c1cbcbcedc9081ed0535d0c67e3f9d2d75c11ff9e847')
pkgver() {
cd fred
@@ -59,16 +46,13 @@ pkgver() {
prepare() {
cd fred
- # Java 14 support
- git pull -r -v https://github.com/skydrome/fred.git gradle-6.6-aur -q
+ # Java 15 support
+ git pull -r -v https://github.com/skydrome/fred.git gradle-6.7-aur -q
rm -f seednodes.fref
for node in "$srcdir"/seedrefs/0* ;do
printf "%s\n\n" "$(<$node)" >>seednodes.fref
done
-
- cd ../plugin-KeyUtils
- patch -Np1 -i "$srcdir/0001-keyutils-fix-constructor-call.patch"
}
build() {
@@ -110,7 +94,7 @@ package() {
# install freenet
install -m755 "$srcdir"/run.sh "$pkgdir"/usr/bin/freenet
install -m640 "$srcdir"/{wrapper.config,IpToCountry.dat} "$pkgdir"/opt/freenet
- install -m640 "$srcdir"/freenet.ini "$pkgdir"/opt/freenet/conf
+ install -m640 "$srcdir"/freenet.ini.dist "$pkgdir"/opt/freenet/conf
install -m640 "$srcdir"/fred/seednodes.fref "$pkgdir"/opt/freenet/noderef
install -m640 "$srcdir"/fred/build/output/*.jar "$pkgdir"/opt/freenet/lib
@@ -119,7 +103,7 @@ package() {
install -m640 "$srcdir"/plugin-$plugin/dist/$plugin.jar "$pkgdir"/opt/freenet/plugins
done
echo "pluginmanager.loadplugin=$(IFS=\;;echo "${_plugins[*]}")" \
- >>"$pkgdir"/opt/freenet/conf/freenet.ini
+ >>"$pkgdir"/opt/freenet/conf/freenet.ini.dist
# delete bundled wrapper
zip -qd "$pkgdir"/opt/freenet/lib/freenet-ext-29.jar "org/tanukisoftware/*"
diff --git a/freenet.ini b/freenet.ini.dist
index 365e5dd04e83..365e5dd04e83 100644
--- a/freenet.ini
+++ b/freenet.ini.dist
diff --git a/freenet.install b/freenet.install
index 85369d20b86b..09857ec60e1a 100644
--- a/freenet.install
+++ b/freenet.install
@@ -7,6 +7,7 @@ post_install() {
freenet &&
echo "ok" || echo "fail"
}
+ cp -v /opt/freenet/conf/freenet.ini{.dist,}
chown -R freenet:freenet /opt/freenet
echo "==> Freenet will be slow during first startup while it discovers the network."
echo "==> You may see 'Data Not Found' or 'Route Not Found' errors, this is normal."
@@ -15,13 +16,6 @@ post_install() {
}
post_upgrade() {
- ## remove me at a later date
- [[ -d /opt/freenet/conf/node ]] && {
- sed -i /opt/freenet/conf/freenet.ini \
- -e "s:node.install.nodeDir=/opt/freenet/conf/node:node.install.nodeDir=/opt/freenet/noderef:" \
- -e "s:JSTUN;::"
- mv /opt/freenet/conf/node /opt/freenet/noderef
- } || true
chown -R freenet:freenet /opt/freenet
}