summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Neuhaus2022-03-29 08:23:44 +0200
committerFrank Neuhaus2022-03-29 08:23:44 +0200
commit7c9496cf545a4e847d404f5391b3d11b18d2b36e (patch)
tree92ab90c9fd6565bbf754cdb69b865ce5bef384a4
parentf9e3a5d9c40b056f984ea8ab380fb49d0481ede5 (diff)
downloadaur-7c9496cf545a4e847d404f5391b3d11b18d2b36e.tar.gz
update to ceres solver 2.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch44
-rw-r--r--PKGBUILD18
3 files changed, 11 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c8179ba60b..1103c6553096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = ceres-solver
pkgdesc = Solver for nonlinear least squares problems
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = http://ceres-solver.org/
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
- depends = google-glog>=0.3.4
+ depends = google-glog>=0.3.5
depends = eigen>=3.3.0
depends = suitesparse>=4.4.5
optdepends = openmp
options = staticlibs
- source = http://ceres-solver.org/ceres-solver-2.0.0.tar.gz
- source = 0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch
- sha256sums = 10298a1d75ca884aa0507d1abb0e0f04800a92871cd400d4c361b56a777a7603
- sha256sums = 3995ecc44dd32cd00c5708a85f8fa9ca6d1deb6a354e7bc89f00d94f243bab76
+ source = http://ceres-solver.org/ceres-solver-2.1.0.tar.gz
+ sha256sums = f7d74eecde0aed75bfc51ec48c91d01fe16a6bf16bce1987a7073286701e2fc6
pkgname = ceres-solver
diff --git a/0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch b/0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch
deleted file mode 100644
index e05d089e1615..000000000000
--- a/0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 941ea13475913ef8322584f7401633de9967ccc8 Mon Sep 17 00:00:00 2001
-From: Alex Stewart <alexs.mac@gmail.com>
-Date: Mon, 15 Mar 2021 14:17:59 +0000
-Subject: [PATCH] Fix FindTBB version detection with TBB >= 2021.1.1
-
-- Raised as issue #669
-
-Change-Id: Ic2fcaf31aef5e303d19a9caef7d6c679325f554a
----
- cmake/FindTBB.cmake | 15 ++++++++++++++-
- 1 file changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/cmake/FindTBB.cmake b/cmake/FindTBB.cmake
-index 5ae7b61..10e540d 100644
---- a/cmake/FindTBB.cmake
-+++ b/cmake/FindTBB.cmake
-@@ -429,10 +429,23 @@ findpkg_finish(TBB_MALLOC_PROXY tbbmalloc_proxy)
- #=============================================================================
- #parse all the version numbers from tbb
- if(NOT TBB_VERSION)
-+ set(TBB_VERSION_FILE_PRIOR_TO_TBB_2021_1
-+ "${TBB_INCLUDE_DIR}/tbb/tbb_stddef.h")
-+ set(TBB_VERSION_FILE_AFTER_TBB_2021_1
-+ "${TBB_INCLUDE_DIR}/oneapi/tbb/version.h")
-+
-+ if (EXISTS "${TBB_VERSION_FILE_PRIOR_TO_TBB_2021_1}")
-+ set(TBB_VERSION_FILE "${TBB_VERSION_FILE_PRIOR_TO_TBB_2021_1}")
-+ elseif (EXISTS "${TBB_VERSION_FILE_AFTER_TBB_2021_1}")
-+ set(TBB_VERSION_FILE "${TBB_VERSION_FILE_AFTER_TBB_2021_1}")
-+ else()
-+ message(FATAL_ERROR "Found TBB installation: ${TBB_INCLUDE_DIR} "
-+ "missing version header.")
-+ endif()
-
- #only read the start of the file
- file(STRINGS
-- "${TBB_INCLUDE_DIR}/tbb/tbb_stddef.h"
-+ "${TBB_VERSION_FILE}"
- TBB_VERSION_CONTENTS
- REGEX "VERSION")
-
---
-2.34.1
-
diff --git a/PKGBUILD b/PKGBUILD
index ce747dd09de8..ee4372336779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Contributor: dtag <dtag00@gmail.com>
pkgname=ceres-solver
-pkgver=2.0.0
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Solver for nonlinear least squares problems"
arch=('i686' 'x86_64')
url="http://ceres-solver.org/"
license=('LGPL')
makedepends=('cmake')
-depends=('google-glog>=0.3.4' 'eigen>=3.3.0'
+depends=('google-glog>=0.3.5' 'eigen>=3.3.0'
'suitesparse>=4.4.5')
optdepends=('openmp')
-source=("http://ceres-solver.org/ceres-solver-2.0.0.tar.gz" "0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch")
-sha256sums=('10298a1d75ca884aa0507d1abb0e0f04800a92871cd400d4c361b56a777a7603'
- '3995ecc44dd32cd00c5708a85f8fa9ca6d1deb6a354e7bc89f00d94f243bab76')
+source=("http://ceres-solver.org/ceres-solver-2.1.0.tar.gz")
+sha256sums=('f7d74eecde0aed75bfc51ec48c91d01fe16a6bf16bce1987a7073286701e2fc6')
options=('staticlibs')
_cmakeopts=('-D CMAKE_BUILD_TYPE=Release'
@@ -24,16 +23,11 @@ _cmakeopts=('-D CMAKE_BUILD_TYPE=Release'
'-D BUILD_EXAMPLES=OFF'
'-D BUILD_BENCHMARKS=OFF')
-prepare() {
- # apply compile fix for tbb (backported from git repo)
- patch --directory="$pkgname-$pkgver" --forward --strip=1 --input="$srcdir/0001-Fix-FindTBB-version-detection-with-TBB-2021.1.1.patch"
-}
-
build() {
cd $srcdir/$pkgname-$pkgver
mkdir -p ./build
cd ./build
- cmake ${_cmakeopts[@]} ../ -DLIB_SUFFIX=""
+ cmake ${_cmakeopts[@]} ../
make
}