summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-07 12:22:51 -0700
committerMark Wagie2023-11-07 12:22:51 -0700
commit7ee5ea6981c47a5e4ff734a4c1626b1704c620ec (patch)
tree4b8e3b3a52cbb059d80bcfd1521d8973e867c470
parent288137dcfbaac69f3916236333c51c87b6f0c5ef (diff)
downloadaur-7ee5ea6981c47a5e4ff734a4c1626b1704c620ec.tar.gz
minor PKGBUILD improvements
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dc907390d86..3de9b9cdb5fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pop-launcher-git
- pkgver = 1.2.1.r47.gce2ba21
- pkgrel = 2
+ pkgver = 1.2.1.r51.gb1f6002
+ pkgrel = 1
url = https://github.com/pop-os/launcher
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 1ad9cee068c3..a3e960e64a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=('pop-launcher-git' 'pop-shell-plugin-system76-power-git')
pkgbase=pop-launcher-git
-pkgver=1.2.1.r47.gce2ba21
-pkgrel=2
+pkgver=1.2.1.r51.gb1f6002
+pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/launcher"
license=('MPL2')
@@ -13,12 +13,12 @@ source=('git+https://github.com/pop-os/launcher.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/launcher"
+ cd launcher
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/launcher"
+ cd launcher
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
just vendor
@@ -31,14 +31,14 @@ prepare() {
}
build() {
- cd "$srcdir/launcher"
+ cd launcher
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
just build-vendored
}
check() {
- cd "$srcdir/launcher"
+ cd launcher
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
just check
@@ -50,7 +50,7 @@ package_pop-launcher-git() {
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
- cd "$srcdir/launcher"
+ cd launcher
install -Dm755 "target/release/${pkgname%-git}-bin" "$pkgdir/usr/bin/${pkgname%-git}"
just rootdir="$pkgdir" install-plugins install-scripts
@@ -65,7 +65,7 @@ package_pop-shell-plugin-system76-power-git() {
conflicts=("${pkgname%-git}" 'pop-launcher-system76-power')
replaces=('pop-launcher-system76-power-git')
- cd "$srcdir/launcher"
+ cd launcher
install -d "$pkgdir/usr/lib/${pkgbase%-git}/scripts"
cp -r scripts/system76-power "$pkgdir/usr/lib/${pkgbase%-git}/scripts"
}