summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Fischer2018-03-05 23:23:39 +0100
committerAaron Fischer2018-03-05 23:23:39 +0100
commit7fc888bea6edad3f751deee5eff6613b337546f6 (patch)
treec3ed2b1b610c572fbd0633f195a4a6e0ee95c592
parent39f8cd0de0a519be65b56cef3587945c858d50a8 (diff)
downloadaur-7fc888bea6edad3f751deee5eff6613b337546f6.tar.gz
Remove isl as a dependency and use the bundled version
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42a90df66eb0..03fa56623c8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,24 @@
pkgname=cloog
pkgver=0.18.5
-pkgrel=1
+pkgrel=2
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-depends=('isl>=0.18' 'osl')
+
+# cloog is not compatible with isl 0.19, so we use the bundled
+# version of isl, see https://github.com/periscop/cloog/issues/37
+depends=('osl')
+#depends=('isl>=0.18' 'osl')
+
source=(https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
sha256sums=('48602a72aaec8e1dabc33ec0622739d3ad585b7f0ec480eebdc1d724822b7cfd')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-isl=system --with-osl=system
+ ./configure --prefix=/usr --with-osl=system
+ #./configure --prefix=/usr --with-isl=system --with-osl=system
make
}