summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Steinbeißer2023-04-18 18:36:16 +0200
committerSebastian Steinbeißer2023-04-18 20:56:31 +0200
commit82b743009561c0f66b478a8a0ffcfd4ff6ec480d (patch)
tree33aa4d435dcb580312039b10f5316c38aca47214
parent3f38c5311d26e76a0851c35ddae4bc365ba66380 (diff)
downloadaur-82b743009561c0f66b478a8a0ffcfd4ff6ec480d.tar.gz
Add .gitignore & some small adaptations to prevent
globbing/splitting.
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c877b92e42c9..34a5c3f74598 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = texlive-installer
pkgdesc = This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed.
pkgver = 2023
- pkgrel = 2
+ pkgrel = 3
url = http://www.tug.org/texlive/
install = texlive-installer.install
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..09cdd2597216
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+install-tl-unx.tar.gz
+pkg/
+src/
+texlive-installer-[0-9][0-9][0-9][0-9]-[0-9]*-any.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 8c36a5ab9dfa..0ceb52f6051a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Yichao Zhou <broken.zhou@gmail.com>
+# Maintainer: gothicVI <sebastian [dot] steinbeisser [at] googlemail [dot] com>
pkgname=texlive-installer
pkgver=2023
-pkgrel=2
-pkgdesc="This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed."
+pkgrel=3
+pkgdesc="This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed."
url="http://www.tug.org/texlive/"
arch=('any')
license=('GPL')
@@ -13,12 +14,12 @@ replaces=()
provides=('texlive-bin' 'texlive-htmlxml' "texlive-formatsextra=${pkgver}" $(pacman -Sgq texlive-most texlive-lang))
source=("http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
md5sums=('SKIP')
-install=${pkgname}.install
+install="${pkgname}".install
package() {
- rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/wget
- rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/xz
+ rm -r "${srcdir}"/install-tl-[0-9]*/tlpkg/installer/wget
+ rm -r "${srcdir}"/install-tl-[0-9]*/tlpkg/installer/xz
- install -d "$pkgdir"/opt
- cp -R ${srcdir}/install-tl-[0-9]*/ "$pkgdir"/opt/texlive-installer
+ install -d "${pkgdir}"/opt
+ cp -R "${srcdir}"/install-tl-[0-9]*/ "${pkgdir}"/opt/texlive-installer
}