summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Reis2018-10-28 15:09:25 -0300
committerGustavo Reis2018-10-28 15:09:25 -0300
commit83ac599a00bc03697c9b2eb73fe26ba05137c206 (patch)
tree50b9b441d316e1a14a3aed0f5abf55b876c582ba
parent91fe935e3a93fa82d93420107d40609bbf76ac0b (diff)
downloadaur-83ac599a00bc03697c9b2eb73fe26ba05137c206.tar.gz
Added Makefile
-rw-r--r--.SRCINFO4
-rwxr-xr-x[-rw-r--r--]CHANGELOG21
-rw-r--r--PKGBUILD13
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 773420d7ce8f..30ad7570a92c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = suru-plus-git
pkgdesc = Suru++ 20 — A cyberpunk, elegant, futuristic and modern third-party icons theme!
- pkgver = 20.3.0
- pkgrel = 4
+ pkgver = 20.3.2
+ pkgrel = 1
url = https://github.com/gusbemacbe/suru-plus
changelog = CHANGELOG
arch = any
diff --git a/CHANGELOG b/CHANGELOG
index 9698c9fb9777..a3ae857ae001 100644..100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,20 @@
-# 20.3.1-2
+GREEN='\033[0;32m'
+ORANGE='\033[0;33m'
+PURPLE='\033[0;35m'
+RED='\033[0;31m'
-* Fixed the wrong upgrade version
+LGREEN='\033[1;32m'
+YELLOW='\033[1;33m'
+LPURPLE='\033[1;35m'
+LRED='\033[1;31m'
+WHITE='\033[1;37m'
+
+NC='\033[0m' # No Color
+
+echo -e "${GREEN}#${NC} ${ORANGE}20.3.2${NC}"
+echo -e "* “Clean” to “uninstall” fixed by @jonathonf"
+
+echo -e " "
+
+echo -e "${GREEN}#${NC} ${ORANGE}20.3.1${NC}"
+echo -e "* Makefile added by @jonathonf"
diff --git a/PKGBUILD b/PKGBUILD
index 31d90f6b2f30..ac072dcdac60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Contributor: Daniel Miranda (dmiranda)
# Contributor: Fabio ‘Lolix’ Loli <lolix at disroot dot org>
+# Contributor: Jonathon <jonathonf>
# Maintainer: Gustavo Costa (gusbemacbe)
pkgname=suru-plus-git
-pkgver=20.3.0
-pkgrel=4
+pkgver=20.3.2
+pkgrel=1
pkgdesc="Suru++ 20 — A cyberpunk, elegant, futuristic and modern third-party icons theme!"
arch=('any')
url="https://github.com/gusbemacbe/${pkgname/-git/}"
@@ -18,12 +19,10 @@ sha256sums=('SKIP')
pkgver()
{
- cd ${pkgname/-git/}
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C ${pkgname/-git/} describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
package()
{
- install -d $pkgdir/usr/share/icons/Suru++\ 20
- cp -r ${pkgname/-git/}/* $pkgdir/usr/share/icons/Suru++\ 20
-} \ No newline at end of file
+ make -C ${pkgname/-git/} PREFIX="$pkgdir"/usr install
+}