summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2018-03-20 14:25:46 -0300
committerLucas Heitzmann Gabrielli2018-03-20 14:25:46 -0300
commit85c9fbbff86965f07b529720e43677c86f4782be (patch)
tree618039a7c445905ed0dc3525b88d05c319a35fc9
parent44badbc98a577af2102e11d83eb6238e262ed4a4 (diff)
downloadaur-85c9fbbff86965f07b529720e43677c86f4782be.tar.gz
Remove examples, add .so links
-rw-r--r--.SRCINFO9
-rw-r--r--Makefile.inc14
-rwxr-xr-xPKGBUILD42
3 files changed, 35 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1581ada71b2b..72aeae202e05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mumps
pkgdesc = Sparse solver library using Gaussian elimination
pkgver = 5.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://mumps.enseeiht.fr
arch = i686
arch = x86_64
@@ -10,13 +10,16 @@ pkgbase = mumps
depends = openmpi
depends = scotch>=6.0.3-3
depends = scalapack
- depends = metis
+ depends = parmetis
depends = zlib
depends = bzip2
+ provides = mumps
+ conflicts = mumps-par
+ conflicts = mumps4
source = http://mumps.enseeiht.fr/MUMPS_5.1.2.tar.gz
source = Makefile.inc
sha256sums = eb345cda145da9aea01b851d17e54e7eef08e16bfa148100ac1f7f046cd42ae9
- sha256sums = a19770669d0e0f1de47b1173f4aaeca405d93492966078fecc344abc37cc1b67
+ sha256sums = f0c6ecc355fc11a0213a2acecbe5b196e3678f93344eea724d6a9aba85dcbf52
pkgname = mumps
diff --git a/Makefile.inc b/Makefile.inc
index eda8c83c9ead..1ddb1af4a015 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -9,7 +9,7 @@
# This defines some parameters dependent on your platform; you should
# look for the approriate file in the directory ./Make.inc/ and copy it
# into a file called Makefile.inc. For example, from the MUMPS root
-# directory, use
+# directory, use
# "cp Make.inc/Makefile.inc.generic ./Makefile.inc"
# (see the main README file for details)
#
@@ -46,7 +46,7 @@ ISCOTCH = -I$(SCOTCHDIR)/include/scotch
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
# sequential analysis choose the first (remember to add -Dscotch in the ORDERINGSF
-# variable below); for both parallel and sequential analysis choose the second
+# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dptscotch in the ORDERINGSF variable below)
LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lbz2 -lz -lscotch -lscotcherr
@@ -63,7 +63,7 @@ IMETIS = -I/usr/include/metis
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
# sequential analysis choose the first (remember to add -Dmetis in the ORDERINGSF
-# variable below); for both parallel and sequential analysis choose the second
+# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dparmetis in the ORDERINGSF variable below)
LMETIS = -L$(LMETISDIR) -lmetis
@@ -88,12 +88,12 @@ IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
# DEFINE HERE SOME COMMON COMMANDS, THE COMPILER NAMES, ETC...
# PLAT : use it to add a default suffix to the generated libraries
-PLAT =
+PLAT =
# Library extension, + C and Fortran "-o" option
# may be different under Windows
LIBEXT = .a
-OUTC = -o
-OUTF = -o
+OUTC = -o
+OUTF = -o
# RM : remove files
RM = /bin/rm -f
# CC : C compiler
@@ -164,5 +164,5 @@ LIBSEQNEEDED = libseqneeded
#Parallel:
INCS = $(INCPAR)
LIBS = $(LIBPAR)
-#LIBSEQNEEDED =
+#LIBSEQNEEDED =
diff --git a/PKGBUILD b/PKGBUILD
index 061a11e010f4..762d460f9074 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,27 @@
# Contributor: Lucas H. Gabrielli
pkgname=mumps
pkgver=5.1.2
-pkgrel=1
-pkgdesc="Sparse solver library using Gaussian elimination"
-url="http://mumps.enseeiht.fr"
-license=("custom")
-depends=('lapack' 'openmpi' 'scotch>=6.0.3-3' 'scalapack' 'metis' 'zlib' 'bzip2')
+pkgrel=2
+pkgdesc='Sparse solver library using Gaussian elimination'
+url='http://mumps.enseeiht.fr'
+license=('custom')
+depends=('lapack' 'openmpi' 'scotch>=6.0.3-3' 'scalapack' 'parmetis' 'zlib' 'bzip2')
makedepends=()
-provides=()
-conflicts=()
+provides=('mumps')
+conflicts=('mumps-par' 'mumps4')
replaces=()
backup=()
arch=('i686' 'x86_64')
source=(http://mumps.enseeiht.fr/MUMPS_${pkgver}.tar.gz
Makefile.inc)
sha256sums=('eb345cda145da9aea01b851d17e54e7eef08e16bfa148100ac1f7f046cd42ae9'
- 'a19770669d0e0f1de47b1173f4aaeca405d93492966078fecc344abc37cc1b67')
+ 'f0c6ecc355fc11a0213a2acecbe5b196e3678f93344eea724d6a9aba85dcbf52')
build() {
cd "${srcdir}/MUMPS_${pkgver}"
cp "${srcdir}/Makefile.inc" .
- make -j1 all || return 1
+ make -j1 alllib || return 1
}
package(){
@@ -37,10 +37,11 @@ package(){
install -m 755 -d "${pkgdir}/usr/lib" || return 1
install -D -m644 lib*.a ${pkgdir}/usr/lib || return 1
for _FILE in `ls *.a | sed "s|\.a||"`; do
- ld -Bshareable -o ${_FILE}.so.${pkgver} -x -soname ${_FILE}.so --whole-archive ${_FILE}.a
- install -m 644 -D ${_FILE}.a ${pkgdir}/usr/lib/${_FILE}.a
- install -m 755 ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib
- ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so.${pkgver:0:1}
+ ld -Bshareable -o ${_FILE}.so.${pkgver} -x -soname ${_FILE}.so --whole-archive ${_FILE}.a
+ install -m 644 -D ${_FILE}.a ${pkgdir}/usr/lib/${_FILE}.a
+ install -m 755 ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib
+ ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so.${pkgver:0:1}
+ ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so
done
# Install libraries mpiseq
@@ -50,19 +51,20 @@ package(){
cd "${srcdir}/MUMPS_${pkgver}/libseq"
install -D -m644 lib*.a ${pkgdir}/usr/lib
for _FILE in `ls *.a | sed "s|\.a||"`; do
- ld -Bshareable -o ${_FILE}.so.${pkgver} -x -soname ${_FILE}.so --whole-archive ${_FILE}.a
- install -m 644 -D ${_FILE}.a ${pkgdir}/usr/lib/${_FILE}.a
- install -m 755 ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib
- ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so.${pkgver:0:1}
+ ld -Bshareable -o ${_FILE}.so.${pkgver} -x -soname ${_FILE}.so --whole-archive ${_FILE}.a
+ install -m 644 -D ${_FILE}.a ${pkgdir}/usr/lib/${_FILE}.a
+ install -m 755 ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib
+ ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so.${pkgver:0:1}
+ ln -sf ${_FILE}.so.${pkgver} ${pkgdir}/usr/lib/${_FILE}.so
done
# Install examples
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}/examples"
cd "${srcdir}/MUMPS_${pkgver}/examples"
install -m 644 * "${pkgdir}/usr/share/doc/${pkgname}/examples"
- for _FILE in ssimpletest dsimpletest csimpletest zsimpletest c_example; do
- chmod 0755 "${pkgdir}/usr/share/doc/${pkgname}/examples/${_FILE}"
- done
+ #for _FILE in ssimpletest dsimpletest csimpletest zsimpletest c_example; do
+ # chmod 0755 "${pkgdir}/usr/share/doc/${pkgname}/examples/${_FILE}"
+ #done
# Install license
install -D -m644 "${srcdir}/MUMPS_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"