summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-01-28 10:34:45 +0100
committerJiří Klimeš2020-01-28 14:00:40 +0100
commit85dadda75f93fbdbb5102d8aa13dff3fb5219b90 (patch)
tree7fefbbfb414c15272d5b08cb056950ecceacdcbd
parent938c0da9a0b34165c2ed3bd80da3291c44040891 (diff)
downloadaur-85dadda75f93fbdbb5102d8aa13dff3fb5219b90.tar.gz
3.28 finally uses webkit2gtk instead of obsolete webkitgtk
This is a good thing because the obsolete webkitgtk has many security-related issues. And the change also saves the compilation time, because webkitgtk was only available in AUR and it is a huge package [1]. [1] https://aur.archlinux.org/packages/webkitgtk/#pinned-690142
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ea6d7102e6..cd52dfb7e0ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = iup
makedepends = lsb-release
makedepends = libcd
makedepends = ftgl
- makedepends = webkitgtk
+ makedepends = webkit2gtk
makedepends = openmotif
makedepends = libxpm
makedepends = lua
@@ -26,7 +26,7 @@ pkgname = iup
pkgdesc = C cross platform GUI toolkit
depends = libcd
depends = ftgl
- depends = webkitgtk
+ depends = webkit2gtk
depends = openmotif
depends = libxpm
diff --git a/PKGBUILD b/PKGBUILD
index 526c6c686d75..2c10fd42db78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ license=('MIT')
makedepends=('lsb-release'
'libcd'
'ftgl'
- 'webkitgtk'
+ 'webkit2gtk'
'openmotif'
'libxpm'
'lua'
@@ -147,7 +147,7 @@ _lua_iup_package_helper() {
package_iup() {
pkgdesc="C cross platform GUI toolkit"
- depends=('libcd' 'ftgl' 'webkitgtk' 'openmotif' 'libxpm')
+ depends=('libcd' 'ftgl' 'webkit2gtk' 'openmotif' 'libxpm')
_linux_ver="Linux$(uname -r | awk -v FS='.' -v OFS='' {'print $1,$2'})_64"