aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2020-01-22 08:13:05 -1000
committerGaetan Bisson2020-01-22 08:13:05 -1000
commit87d2f694b0bcbd173d956f769f975ca2344304fb (patch)
tree7f826219f5f1e5713d1eeb7ad35704caf721f0e0
parent991be698e97f2e74e38a6b38ec16c968f2ee249a (diff)
downloadaur-87d2f694b0bcbd173d956f769f975ca2344304fb.tar.gz
various improvements
-rw-r--r--PKGBUILD8
-rw-r--r--README10
-rwxr-xr-xarch.build4
3 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a8d56448887..245c9d06bed1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=buildstuff
-pkgver=1.8
+pkgver=1.9
pkgrel=1
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
@@ -23,7 +23,7 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-sha256sums=('6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d'
+sha256sums=('f7ed61b7826b657ab32d715567642f86e824374e16d9637d40ffc7d21c7ecfae'
'acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960'
- '12d4c4033073cc940b26581d3008c865145cd1bbe0f64491bff522922370d003'
- '8f33b668ab81dcefd62191c3a01d596d498b8ba1058368dbb1ca2a2a2bf89218')
+ '82aafa6d8f46294d39686f2afe17b323db65f7fab0b239b740805046b13703cc'
+ '90ecf020399db72ce0ac8e1eb05759652363c029c06616b770cd273b7923ae97')
diff --git a/README b/README
index e540523ec14b..bf8ef0a75810 100644
--- a/README
+++ b/README
@@ -5,9 +5,9 @@ From a directory that contains a PKGBUILD, run:
arch.build i686
-This will build the package for the given architecture. You may also append a
-list of repositories to use on top of [core], [extra], and [community], for
-instance:
+This will build the package for the given architecture. You may also
+append a list of repositories to use on top of [core], [extra], and
+[community], for instance:
arch.build x86_64 testing multilib-testing multilib
@@ -19,7 +19,9 @@ Enable hardware virtualization.
Make /tmp a tmpfs. (This is where the copy-on-write drive is stored.)
-Install a caching pacman mirror proxy on your local network and use it.
+Use a fast package mirror, ideally a caching proxy on your local network.
+Entries from /etc/pacman.d/mirrorlist are used as-is except that 127.0.0.1 gets
+translated to 10.0.2.2 which is the host address from the qemu guest viewpoint.
REQUIREMENTS FOR ARCH.INSTALL
diff --git a/arch.build b/arch.build
index 44c35a5ee29b..183bfefa3b04 100755
--- a/arch.build
+++ b/arch.build
@@ -24,7 +24,7 @@ vhost="
start_vm() {
qemu-system-x86_64 \
-cpu $cpu -smp 4 -m 2G \
- -accel kvm:tcg,thread=multi \
+ -machine accel=kvm:tcg \
-device virtio-net,netdev=vlan \
-netdev user,id=vlan,hostfwd=::$vport-:22 \
-drive file=$1 &
@@ -87,6 +87,6 @@ sftp $vhost <<<"put $HOME/.gnupg/pubring.kbx .gnupg/pubring.kbx"
sftp $vhost <<<'put -r . /build' # fake chroot build for db-update
ssh $vhost 'rm -fr /build/{src,pkg}' # fix source repo relocation
ssh $vhost 'cd /build; makepkg --log --noconfirm --syncdeps'
-sftp $vhost <<<'get /build/*.pkg.tar.xz'
+sftp $vhost <<<'get /build/*.pkg.tar.*'
sftp $vhost <<<'get /build/*.log'
stop_vm