summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2024-04-13 14:37:29 +0100
committerScore_Under2024-04-13 14:37:29 +0100
commit87e20537df0b76e8eed453a1ab283b85f3c3a00f (patch)
treee946879c0561f399df4c59db96b69d4fa0571375
parenta70847077c31f71dbc17b6f5a1d75da32220ba23 (diff)
downloadaur-87e20537df0b76e8eed453a1ab283b85f3c3a00f.tar.gz
Update for v570 and oh my god not again
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--hydrus-client2
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d8625220a84..94ff168f0a4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 569
+ pkgver = 570
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -28,7 +28,7 @@ pkgbase = hydrus
depends = python-service-identity
depends = qt6-multimedia
depends = qt6-svg
- depends = pyside6
+ depends = python-pyqt6
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
@@ -45,14 +45,14 @@ pkgbase = hydrus
optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs-dummy
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=c7cac8e2999018ab375fa7ae8cefd36101ad8326
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=abaea811340afa9262e230e77d263f2b2348718f
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
- sha256sums = SKIP
+ sha256sums = 2fc593c662151f4cbe79f9d7926e322a6c5a2e55358b4f21a456e561ab95b923
sha256sums = f9f5a5927c7f2c016dbab3e4135a921918617ba393babd9b6a903ff5d0154cdd
- sha256sums = 39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0
+ sha256sums = b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68
sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 1946d23bd997..a0af34bc3157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=569
+pkgver=570
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -17,7 +17,7 @@ depends=(python python-opencv python-beautifulsoup4 python-yaml
python-service-identity # required by twisted for https hostname verification
qt6-multimedia # https://aur.archlinux.org/packages/hydrus#comment-914337
qt6-svg # https://aur.archlinux.org/packages/hydrus#comment-923550
- pyside6)
+ python-pyqt6)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
@@ -37,14 +37,14 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
conflicts=(hydrus-docs-dummy)
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=c7cac8e2999018ab375fa7ae8cefd36101ad8326"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=abaea811340afa9262e230e77d263f2b2348718f"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
-sha256sums=('SKIP'
+sha256sums=('2fc593c662151f4cbe79f9d7926e322a6c5a2e55358b4f21a456e561ab95b923'
'f9f5a5927c7f2c016dbab3e4135a921918617ba393babd9b6a903ff5d0154cdd'
- '39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0'
+ 'b1854ecac184385f0aa48fcefd426223fac3eeec0f1180ba58b6a58b03257d68'
'5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/hydrus-client b/hydrus-client
index e3ee4e9ab70f..060d2ef97178 100644
--- a/hydrus-client
+++ b/hydrus-client
@@ -1,2 +1,4 @@
#!/bin/sh
+: "${QT_API:=pyqt6}"
+export QT_API
exec python -OO /opt/hydrus/hydrus_client.py "$@"