summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbenklett2023-12-10 17:28:04 +0100
committerbenklett2023-12-10 17:30:50 +0100
commit8954dc9e90384e9a98ca72b469b3bdbd87518eb5 (patch)
treea15f8a466a264355a600b1071245ff58b2b2196c
parent5a6d200a207cc4127e9006e1cfae49cee4ea6ae9 (diff)
downloadaur-8954dc9e90384e9a98ca72b469b3bdbd87518eb5.tar.gz
chore: Update package, sort/cleanup dependencies
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD56
-rw-r--r--fix_python_binary_loading.patch24
3 files changed, 55 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b10fce47d71..f558894bb0e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,44 @@
pkgbase = obs-studio-git
pkgdesc = Free and open source software for video recording and live streaming.
- pkgver = 30.0.0.beta3
- pkgrel = 2
+ pkgver = 30.0.0.rc1
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
license = GPL2
makedepends = asio
+ makedepends = cef-minimal-obs-bin
makedepends = cmake
makedepends = git
makedepends = libfdk-aac
makedepends = libxcomposite
- makedepends = x264
- makedepends = vlc
- makedepends = swig
makedepends = luajit
makedepends = nlohmann-json
+ makedepends = pipewire
makedepends = python
- makedepends = cef-minimal-obs-bin
+ makedepends = qt6-wayland
+ makedepends = swig
+ makedepends = vlc
makedepends = wayland
makedepends = websocketpp
- makedepends = qt6-wayland
- makedepends = pipewire
+ makedepends = x264
makedepends = xdg-desktop-portal
+ depends = curl
depends = ffmpeg
+ depends = gtk-update-icon-cache
+ depends = jack
depends = jansson
+ depends = libajantv2
+ depends = libdatachannel
+ depends = librist
depends = libxinerama
depends = libxkbcommon-x11
depends = mbedtls2
- depends = qt6-svg
- depends = curl
- depends = jack
- depends = gtk-update-icon-cache
- depends = speexdsp
- depends = pciutils
- depends = libajantv2
- depends = librist
depends = onevpl
- depends = libdatachannel
+ depends = pciutils
depends = qrcodegencpp-cmake
+ depends = qt6-svg
+ depends = speexdsp
optdepends = libfdk-aac: FDK AAC codec support
optdepends = libxcomposite: XComposite capture support
optdepends = libva-intel-driver: hardware encoding
@@ -50,19 +50,15 @@ pkgbase = obs-studio-git
optdepends = pipewire: Pipewire capture
optdepends = pipewire-media-session: Pipewire capture
optdepends = xdg-desktop-portal: Pipewire capture
- provides = obs-studio=30.0.0.beta3
+ provides = obs-studio=30.0.0.rc1
conflicts = obs-studio
source = obs-studio-git::git+https://github.com/obsproject/obs-studio.git#branch=master
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
source = git+https://github.com/obsproject/obs-websocket.git
- source = git+https://github.com/nayuki/QR-Code-generator.git
- source = fix_python_binary_loading.patch
- md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 051b90f05e26bff99236b8fb1ad377d1
pkgname = obs-studio-git
diff --git a/PKGBUILD b/PKGBUILD
index 936eeb54d93a..0baff1e53292 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,45 @@
# Contributor: ArcticVanguard <LideEmily at gmail dot com>
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-git
-pkgver=30.0.0.beta3
-pkgrel=2
+pkgver=30.0.0.rc1
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
-depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls2"
- "qt6-svg" "curl" "jack" "gtk-update-icon-cache"
- "speexdsp" "pciutils" "libajantv2" "librist" "onevpl"
- "libdatachannel" "qrcodegencpp-cmake")
-makedepends=("asio" "cmake" "git" "libfdk-aac" "libxcomposite" "x264"
- "vlc" "swig" "luajit" "nlohmann-json" "python" "cef-minimal-obs-bin" "wayland"
- "websocketpp" "qt6-wayland" "pipewire" "xdg-desktop-portal")
+depends=("curl"
+ "ffmpeg"
+ "gtk-update-icon-cache"
+ "jack"
+ "jansson"
+ "libajantv2"
+ "libdatachannel"
+ "librist"
+ "libxinerama"
+ "libxkbcommon-x11"
+ "mbedtls2"
+ "onevpl"
+ "pciutils"
+ "qrcodegencpp-cmake"
+ "qt6-svg"
+ "speexdsp")
+makedepends=("asio"
+ "cef-minimal-obs-bin"
+ "cmake"
+ "git"
+ "libfdk-aac"
+ "libxcomposite"
+ "luajit"
+ "nlohmann-json"
+ "pipewire"
+ "python"
+ "qt6-wayland"
+ "swig"
+ "vlc"
+ "wayland"
+ "websocketpp"
+ "x264"
+ "xdg-desktop-portal")
optdepends=("libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
"libva-intel-driver: hardware encoding"
@@ -32,11 +58,8 @@ conflicts=("obs-studio")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
- "git+https://github.com/obsproject/obs-websocket.git"
- "git+https://github.com/nayuki/QR-Code-generator.git"
- "fix_python_binary_loading.patch")
-md5sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
- "051b90f05e26bff99236b8fb1ad377d1")
+ "git+https://github.com/obsproject/obs-websocket.git")
+md5sums=("SKIP" "SKIP" "SKIP" "SKIP")
pkgver() {
cd $pkgname
@@ -47,15 +70,10 @@ prepare() {
cd $pkgname
gitconf="protocol.file.allow=always"
- patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
git -c $gitconf submodule update
-
- cd plugins/obs-websocket
- git config submodule.deps/qr.url $srcdir/QR-Code-generator
- git -c $gitconf submodule update
}
build() {
diff --git a/fix_python_binary_loading.patch b/fix_python_binary_loading.patch
deleted file mode 100644
index 6cba55f2f1af..000000000000
--- a/fix_python_binary_loading.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From c482159ce93deafc7f1fc5755ba15135709ae726 Mon Sep 17 00:00:00 2001
-From: Matt Gajownik <matt@obsproject.com>
-Date: Tue, 25 Aug 2020 19:28:26 +1000
-Subject: [PATCH] libobs/util: Fix loading Python binary modules on *nix
-
-Fixes #2222
----
- libobs/util/platform-nix.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/libobs/util/platform-nix.c b/libobs/util/platform-nix.c
-index 26800d52f7..997b62db1a 100644
---- a/libobs/util/platform-nix.c
-+++ b/libobs/util/platform-nix.c
-@@ -71,7 +71,8 @@ void *os_dlopen(const char *path)
- #ifdef __APPLE__
- void *res = dlopen(dylib_name.array, RTLD_LAZY | RTLD_FIRST);
- #else
-- void *res = dlopen(dylib_name.array, RTLD_LAZY);
-+ void *res = dlopen(dylib_name.array,
-+ RTLD_LAZY | RTLD_DEEPBIND | RTLD_GLOBAL);
- #endif
- if (!res)
- blog(LOG_ERROR, "os_dlopen(%s->%s): %s\n", path,