summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReto Brunner2023-06-23 11:11:30 +0200
committerReto Brunner2023-06-23 13:08:23 +0200
commit8abcc80de465cab691e5198598ba722833aa532d (patch)
treef04180cc2e86af5cfc1832545541b30bd0ce445a
parente49577ac552c55601f5f431cadfbdbaa7b3315d3 (diff)
downloadaur-8abcc80de465cab691e5198598ba722833aa532d.tar.gz
bump pkgver to latest
-rw-r--r--.SRCINFO37
-rw-r--r--.install11
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD48
4 files changed, 47 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5949be071286..0ee416ae74bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,22 @@
pkgbase = limnoria
- pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features
- pkgver = 20210411
+ pkgdesc = A robust, full-featured and user/programmer-friendly Python IRC bot
+ pkgver = 2023.5.27
pkgrel = 1
url = https://github.com/ProgVal/Limnoria
- install = .install
arch = any
- license = 3-clause BSD
- makedepends = git
- depends = python>=3.4
- optdepends = python-charade: Detect page's encoding
- optdepends = python-pytz: Enable Time plugin to calculate the time in specified timezone
- optdepends = python-dateutil: Enable Time plugin to parse the input time string
- optdepends = python-gnupg: GnuPG support
- optdepends = python-feedparser: RSS plugin support
- optdepends = python-sqlalchemy: Aka plugin support
- optdepends = python-pysocks: SOCKS proxy support
- optdepends = python-mock: For testing only
- optdepends = python-cryptography: ECDSA support
- conflicts = limnoria-python3
- conflicts = limnoria-git
- conflicts = limnoria-python3-git
- source = https://github.com/ProgVal/Limnoria/archive/master-2021-04-11.tar.gz
- md5sums = 5822c4292697e35d758d716d0a810327
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-chardet: to detect encoding of incoming IRC lines, if they are not in UTF-8
+ optdepends = python-gnupg: for authenticated based on GPG tokens
+ optdepends = python-pysocks: for SOCKS proxy (typically used to connect to IRC via Tor)
+ optdepends = python-cryptography: required to load the Fediverse plugin (used to implement HTTP signatures)
+ optdepends = python-feedparser: required to load the RSS plugin
+ optdepends = python-dateutil: enable fancy time string parsing in the Time plugin
+ source = https://files.pythonhosted.org/packages/source/l/limnoria/limnoria-2023.5.27.tar.gz
+ sha256sums = 1ea3415c398f534be1d5c034b3058aef4f0c9c270011e891c5fff2696d8e87f5
pkgname = limnoria
-
diff --git a/.install b/.install
deleted file mode 100644
index 5c72e44b1753..000000000000
--- a/.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo "Notice: Since limnoria now only supports python3, "
- echo " Original executive supybot3 in limnoria-python3(-git)"
- echo " has been replaced by supybot."
-}
-
-post_upgrade() {
- echo "Notice: Since limnoria now only supports python3, "
- echo " Original executive supybot3 in limnoria-python3(-git)"
- echo " has been replaced by supybot, same goes for other executives."
-}
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..078bd709f31a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+.PHONY: clean release
+# prevent make from auto guessing and using implicit rules
+.SUFFIXES:
+
+release: clean
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf src limnoria-*
diff --git a/PKGBUILD b/PKGBUILD
index fcc277425622..50deaa181d63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,32 @@
-# Maintainer: Cravix < dr dot neemous at gmail dot com >
+# Maintainer: Reto <reto@sligthlybroken.com>
+# Contributor: Cravix < dr dot neemous at gmail dot com >
pkgname=limnoria
-_pkgname=Limnoria
-pkgver=20210411
-_pkgver=2021-04-11
+pkgver=2023.5.27
pkgrel=1
-pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features"
+pkgdesc="A robust, full-featured and user/programmer-friendly Python IRC bot"
arch=('any')
url="https://github.com/ProgVal/Limnoria"
-license=('3-clause BSD')
-depends=('python>=3.4')
-makedepends=('git')
-optdepends=("python-charade: Detect page's encoding"
- "python-pytz: Enable Time plugin to calculate the time in specified timezone"
- "python-dateutil: Enable Time plugin to parse the input time string"
- "python-gnupg: GnuPG support"
- "python-feedparser: RSS plugin support"
- "python-sqlalchemy: Aka plugin support"
- "python-pysocks: SOCKS proxy support"
- "python-mock: For testing only"
- "python-cryptography: ECDSA support")
-conflicts=('limnoria-python3' 'limnoria-git' 'limnoria-python3-git')
-source=("https://github.com/ProgVal/Limnoria/archive/master-${_pkgver}.tar.gz")
-md5sums=('5822c4292697e35d758d716d0a810327')
-install=".install"
+license=('BSD')
+depends=('python')
+makedepends=(python-build python-installer python-wheel python-setuptools)
+optdepends=(
+'python-chardet: to detect encoding of incoming IRC lines, if they are not in UTF-8'
+'python-gnupg: for authenticated based on GPG tokens'
+'python-pysocks: for SOCKS proxy (typically used to connect to IRC via Tor)'
+'python-cryptography: required to load the Fediverse plugin (used to implement HTTP signatures)'
+'python-feedparser: required to load the RSS plugin'
+'python-dateutil: enable fancy time string parsing in the Time plugin'
+)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('1ea3415c398f534be1d5c034b3058aef4f0c9c270011e891c5fff2696d8e87f5')
build() {
- cd "$srcdir/$_pkgname-master-${_pkgver}"
-
- python3 setup.py build
+ cd "$srcdir/$pkgname-$pkgver" || exit 1
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$_pkgname-master-${_pkgver}"
-
- python3 setup.py install --root="$pkgdir" || return 1
+ cd "$srcdir/$pkgname-$pkgver" || exit 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}