summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLingMan2023-11-25 01:59:05 +0100
committerLingMan2023-11-25 01:59:05 +0100
commit8b962abdd6429694168883dff63f66a6e989b8c8 (patch)
tree002610faa7028ab488b8fca1dce64fde598e44df
parentcff6e82d058f582f77f60a55bcd0942fa61ca564 (diff)
downloadaur-8b962abdd6429694168883dff63f66a6e989b8c8.tar.gz
Switch from swig to swig3
Building with the current swig 4.1.1 causes armory to fail launching with the error "ImportError: cannot import name ConfigFile_fleshOutArgs". Go back to swig 3, which works fine. While at it, make swig a makedependency. It was never needed at runtime.
-rw-r--r--.SRCINFO6
-rw-r--r--0002-Use-swig3.0.patch40
-rw-r--r--PKGBUILD13
3 files changed, 52 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f28b64f1ea5..74a340f0cec8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = armory
pkgdesc = Full-featured Bitcoin wallet management application
pkgver = 0.96.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/goatpig/BitcoinArmory
install = armory.install
arch = i686
@@ -10,8 +10,8 @@ pkgbase = armory
license = MIT
makedepends = gcc
makedepends = make
+ makedepends = swig3
depends = crypto++
- depends = swig
depends = qt4
depends = python2
depends = python2-twisted
@@ -26,9 +26,11 @@ pkgbase = armory
conflicts = armory-goatpig-git
source = https://github.com/goatpig/BitcoinArmory/releases/download/v0.96.5/armory_0.96.5_source.tar.xz
source = 0001-Fix-compilation.patch
+ source = 0002-Use-swig3.0.patch
source = run-armory.sh
sha512sums = aba9627a58414d9a5b9781753d6c09b3970f2728f317419b3dc8547a8ad2b9e7f9615a650a56441122647406ea846c64383677f220f26ef395029cdb8d25812c
sha512sums = 10d10d449652de81d2bdeff5cd2bc72015071354720b80650a243f51a16e2b6da8f0600134ab03364819d0e916ae368a1ef81a5df71cddbf48fe9c1980e99dff
+ sha512sums = eb8f4d55495642747dd4777ebeed309b8b9dbc2a07294748ea2f2c7e97d35111dc4156eeda4c668a624bd05d5ea44957dfbc930484fc1fa0b487661cee7fac18
sha512sums = af44a8edfdf751f3343a8bdf6fa21c125389de3435c4b03c7f581b980525a9f32af177f496830f847b70c8e2619c42908536698e0fd28f862f16083cf7396715
pkgname = armory
diff --git a/0002-Use-swig3.0.patch b/0002-Use-swig3.0.patch
new file mode 100644
index 000000000000..5f59177ee8b0
--- /dev/null
+++ b/0002-Use-swig3.0.patch
@@ -0,0 +1,40 @@
+From 3cba10fc5377be5bded634431b0da72ee301ad33 Mon Sep 17 00:00:00 2001
+From: LingMan <LingMan@users.noreply.github.com>
+Date: Sat, 25 Nov 2023 00:10:32 +0100
+Subject: [PATCH] Use swig3.0
+
+Building with swig4.0 results in "ImportError: cannot import name ConfigFile_fleshOutArgs" at runtime.
+---
+ configure.ac | 2 +-
+ cppForSwig/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index eb0d1c5..3a815b8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -64,7 +64,7 @@ AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory], [nodefault])
+ if test "x$with_gui" = "xyes"; then
+ #check for swig
+
+-AC_CHECK_PROG([HAVE_SWIG], [swig], [yes], [no])
++AC_CHECK_PROG([HAVE_SWIG], [swig3.0], [yes], [no])
+ AS_IF([test $HAVE_SWIG == yes], [],
+ [AC_MSG_ERROR([missing swig!])])
+
+diff --git a/cppForSwig/Makefile.am b/cppForSwig/Makefile.am
+index 6d7e4fe..dabfb19 100644
+--- a/cppForSwig/Makefile.am
++++ b/cppForSwig/Makefile.am
+@@ -100,7 +100,7 @@ endif
+
+ #custom rules
+ CppBlockUtils_wrap.cxx: CppBlockUtils.i
+- swig $(SWIG_FLAGS) CppBlockUtils.i
++ swig3.0 $(SWIG_FLAGS) CppBlockUtils.i
+
+ .PHONY: CppBlockUtils_wrap.cxx
+
+--
+2.42.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 64ff68d2bafe..e1869167746f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Jonathan la Cour <jon@lacour.me>
+# Contributor: Jonathan la Cour <jon@lacour.me>
# Contributor: Patrick Glandien <patrick@synix.io>
# Contributor: William Grieshaber <me@zee.li>
# Contributor: portals <portals at riseup.net> Base on work of: 2bluesc <2bluesc at gmail.com> and mazzolino <maze+aur at strahlungsfrei.de>
@@ -6,13 +6,13 @@
pkgname=armory
pkgver=0.96.5
-pkgrel=1
+pkgrel=2
pkgdesc="Full-featured Bitcoin wallet management application"
arch=('i686' 'x86_64')
url="https://github.com/goatpig/BitcoinArmory"
license=('AGPL3' 'MIT')
-depends=('crypto++' 'swig' 'qt4' 'python2' 'python2-twisted' 'python2-pyqt4' 'python2-bsddb' 'python2-psutil')
-makedepends=('gcc' 'make')
+depends=('crypto++' 'qt4' 'python2' 'python2-twisted' 'python2-pyqt4' 'python2-bsddb' 'python2-psutil')
+makedepends=('gcc' 'make' 'swig3')
optdepends=('bitcoin-daemon: Communicate with the Bitcoin network')
provides=('armory')
conflicts=('armory' 'armory-git' 'armory-bin' 'armory-goatpig-git')
@@ -23,9 +23,11 @@ install="${pkgname}.install"
_signatures="https://github.com/goatpig/BitcoinArmory/releases/download/v${pkgver}/sha256sum.txt.asc"
source=("https://github.com/goatpig/BitcoinArmory/releases/download/v${pkgver}/armory_${pkgver}_source.tar.xz"
'0001-Fix-compilation.patch'
+ '0002-Use-swig3.0.patch'
'run-armory.sh')
sha512sums=('aba9627a58414d9a5b9781753d6c09b3970f2728f317419b3dc8547a8ad2b9e7f9615a650a56441122647406ea846c64383677f220f26ef395029cdb8d25812c'
'10d10d449652de81d2bdeff5cd2bc72015071354720b80650a243f51a16e2b6da8f0600134ab03364819d0e916ae368a1ef81a5df71cddbf48fe9c1980e99dff'
+ 'eb8f4d55495642747dd4777ebeed309b8b9dbc2a07294748ea2f2c7e97d35111dc4156eeda4c668a624bd05d5ea44957dfbc930484fc1fa0b487661cee7fac18'
'af44a8edfdf751f3343a8bdf6fa21c125389de3435c4b03c7f581b980525a9f32af177f496830f847b70c8e2619c42908536698e0fd28f862f16083cf7396715')
_parentdir=Armory3
@@ -46,7 +48,8 @@ check() {
prepare() {
cd "$srcdir/$_parentdir"
- patch --strip=1 --input=../../0001-Fix-compilation.patch
+ patch --strip=1 --input=../0001-Fix-compilation.patch
+ patch --strip=1 --input=../0002-Use-swig3.0.patch
## Get Python2 Version
_py2longver=$(pacman -Qi python2 | grep "Version" | sed 's/^Version\s*:\s//')