summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2023-11-09 08:04:13 +0100
committerTobias Borgert2023-11-09 08:04:13 +0100
commit8ee1d754d1b71b44ee6181c6a62e83774fd1ff3a (patch)
tree51c2598cd743d3d5f2a48ab57db8ca57d86ee353
parentb1925aec18ef1449e9b7aede4e35f94cd618bc55 (diff)
downloadaur-8ee1d754d1b71b44ee6181c6a62e83774fd1ff3a.tar.gz
Update to v5.12.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--ecal-gcc13.patch35
3 files changed, 8 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a059fbe9011a..86da5ccf9eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.11.4
+ pkgver = 5.12.1
pkgrel = 4
url = https://github.com/eclipse-ecal/ecal
arch = x86_64
@@ -25,11 +25,9 @@ pkgbase = ecal
depends = yaml-cpp
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
- source = ecal-5.11.4.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.11.4/ecal-fat-source.tar.gz
- source = ecal-gcc13.patch
+ source = ecal-5.12.1.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.12.1/ecal-fat-source.tar.gz
source = termcolor-gcc13.patch
- sha256sums = 48cc5522d64b01bd110cbfb97ed8990169b8a9713a424f78e231c139244b649b
- sha256sums = 534801dd5ac16cfdf4a3a844ccb9a953c2852d013fd5c80c3d9bbe888583926c
+ sha256sums = 493599b33ea9c3361ff0bd871d95ae6bc3151f4ee763bfb8295aa0d99d551281
sha256sums = df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index 7be23ccf26dc..b8f3b6f4ff5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Borgert <tobias (dot) borgert (at) gmail (dot) com>
pkgname=ecal
-pkgver=5.11.4
+pkgver=5.12.1
pkgrel=4
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
@@ -10,14 +10,12 @@ license=('Apache')
depends=('curl' 'protobuf' 'python' 'python-protobuf' 'qt5-base' 'qwt' 'hdf5' 'yaml-cpp')
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'patchelf' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=()
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz" "ecal-gcc13.patch" "termcolor-gcc13.patch")
-sha256sums=('48cc5522d64b01bd110cbfb97ed8990169b8a9713a424f78e231c139244b649b'
- '534801dd5ac16cfdf4a3a844ccb9a953c2852d013fd5c80c3d9bbe888583926c'
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz" "termcolor-gcc13.patch")
+sha256sums=('493599b33ea9c3361ff0bd871d95ae6bc3151f4ee763bfb8295aa0d99d551281'
'df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
- patch --forward --strip=1 --input="ecal-gcc13.patch"
patch --forward --strip=1 --input="termcolor-gcc13.patch"
}
@@ -33,7 +31,8 @@ build() {
-DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF \
-DECAL_THIRDPARTY_BUILD_CURL=OFF \
-DECAL_THIRDPARTY_BUILD_HDF5=OFF \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_FIND_PACKAGE_PREFER_CONFIG=ON
make
}
diff --git a/ecal-gcc13.patch b/ecal-gcc13.patch
deleted file mode 100644
index 3cb7a5046ade..000000000000
--- a/ecal-gcc13.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Subject: [PATCH] GCC13 compatibility: Explicitly include cstdint
----
-Index: ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h b/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h
---- a/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h (revision 6b2843ad29597e7de06a6f80e99572006eeb097a)
-+++ b/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h (revision 044d473cfda4d70d57ac0a7c081cae0e2cc10ffb)
-@@ -21,6 +21,7 @@
-
- #include <time.h>
- #include <mutex>
-+#include <string>
-
- #define CLOCKFD 3
- #define FD_TO_CLOCKID(fd) ((~(clockid_t) (fd) << 3) | CLOCKFD)
-Index: ecal/ecal/core/src/topic2mcast.h
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/ecal/ecal/core/src/topic2mcast.h b/ecal/ecal/core/src/topic2mcast.h
---- a/ecal/ecal/core/src/topic2mcast.h (revision 6b2843ad29597e7de06a6f80e99572006eeb097a)
-+++ b/ecal/ecal/core/src/topic2mcast.h (revision 044d473cfda4d70d57ac0a7c081cae0e2cc10ffb)
-@@ -23,6 +23,7 @@
-
- #pragma once
-
-+#include <cstdint>
- #include <sstream>
- #include <iostream>
- #include <string>
-