summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2020-05-07 13:10:57 +1000
committerRhinoceros2020-05-07 13:10:57 +1000
commit8f4cb7a9237abe1c254fa433ae143c6b60ab9e23 (patch)
treed793c2c61e6959154e388183947631112eb410f7
parentec2fcee17ea6ea4d5c7f910fda5d7c467283d7a1 (diff)
downloadaur-8f4cb7a9237abe1c254fa433ae143c6b60ab9e23.tar.gz
Update to 1:r13-1
* change pkgdesc as per upstream * hardcode source to specific commit * separate build() from package() * move man page to correct location * install custom (BSD) licence * reorder variables as per Arch conventions * other minor stylistic changes
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40515fb11774..69a81b53c542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = ripmime
- pkgdesc = Tool to extract the attached files out of a MIME package
- pkgver = r13.a556ffe
- pkgrel = 2
+ pkgdesc = MIME/email package decoder
+ pkgver = r13
+ pkgrel = 1
+ epoch = 1
url = https://github.com/inflex/ripMIME
arch = any
license = BSD
makedepends = git
- source = git+https://github.com/inflex/ripMIME
- md5sums = SKIP
+ conflicts = ripmime-git
+ source = git+https://github.com/inflex/ripmime.git#commit=a556ffe08d620602475c976732e8e1a82f3169e9
+ sha256sums = SKIP
pkgname = ripmime
diff --git a/PKGBUILD b/PKGBUILD
index 9124098e34a8..210971e286a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Jenya Sovetkin <e.sovetkin <at> gmail <dot> com>
# Contributor: K. Piche <kpiche <at> rogers <dot> com>
-# Maintainer: Jenya Sovetkin <e.sovetkin <at> gmail <dot> com>
+
pkgname=ripmime
-pkgver=r13.a556ffe
-pkgrel=2
+pkgver=r13
+_commit=a556ffe08d620602475c976732e8e1a82f3169e9
+pkgrel=1
+epoch=1
+pkgdesc='MIME/email package decoder'
arch=(any)
-license=('BSD')
-pkgdesc="Tool to extract the attached files out of a MIME package"
url="https://github.com/inflex/ripMIME"
-source=('git+https://github.com/inflex/ripMIME')
-md5sums=('SKIP')
+license=('BSD')
+conflicts=('ripmime-git')
+source=("git+https://github.com/inflex/${pkgname}.git#commit=$_commit")
+sha256sums=('SKIP')
makedepends=('git')
-_gitname=ripMIME
-
-pkgver() {
- cd "${_gitname}"
-
- # Get the version number.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+build() {
+ cd "${pkgname}"
+ make
}
package() {
- cd "${srcdir}/${_gitname}"
- make || return 1
+ cd "${pkgname}"
mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/man/man1"
make LOCATION="${pkgdir}/usr" install
+
+ # Proper location for man pages
+ mkdir "${pkgdir}/usr/share"
+ mv "${pkgdir}/usr/man" "${pkgdir}/usr/share/man"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}