summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2022-04-16 20:40:27 +0200
committerRobbert van der Helm2022-04-16 20:41:35 +0200
commit906b5ab3e935cc892f37b5a1305e63c276b66bcd (patch)
treef8cfef9db15eae2f467326368a1a030fe533d34c
parentf70aa9e151a783d3875bd222628c773299639042 (diff)
downloadaur-906b5ab3e935cc892f37b5a1305e63c276b66bcd.tar.gz
Update for the chainloading changes
- `boost` and by extension `lib32-boost` are no longer dependencies - `Asio` is is a new dependency, although like all other dependencies a Meson wrap will be used if it's not available - `libyabridge-chainloader-vst2.so` and `libyabridge-chainloader-vst3.so` are new and replace the old `libyabridge-{vst2,vst3}.so` copies. Yabridgectl will also need to be rebuilt to accommodate these changes.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd1298ab269..56e626a7e206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yabridge-git
pkgdesc = A modern and transparent way to use Windows VST2 and VST3 plugins on Linux
- pkgver = 3.7.0.r18.g02118f2a
- pkgrel = 2
+ pkgver = 3.8.1.r73.g9420bade
+ pkgrel = 1
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
arch = x86_64
@@ -10,14 +10,13 @@ pkgbase = yabridge-git
makedepends = meson
makedepends = ninja
makedepends = cmake
+ makedepends = asio
+ makedepends = bitsery
+ makedepends = function2
+ makedepends = lib32-libxcb
depends = wine
- depends = boost
- depends = bitsery
- depends = function2
depends = libxcb
depends = tomlplusplus
- depends = lib32-boost-libs
- depends = lib32-libxcb
optdepends = yabridgectl: utility for setting up and managing yabridge
provides = yabridge
conflicts = yabridge
diff --git a/PKGBUILD b/PKGBUILD
index ed63ce792d52..1122032f0dee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=yabridge-git
_pkgname=yabridge
-pkgver=3.7.0.r18.g02118f2a
-pkgrel=2
+pkgver=3.8.1.r73.g9420bade
+pkgrel=1
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
license=('GPL3')
-depends=('wine' 'boost' 'bitsery' 'function2' 'libxcb' 'tomlplusplus' 'lib32-boost-libs' 'lib32-libxcb')
-makedepends=('git' 'meson' 'ninja' 'cmake')
+depends=('wine' 'libxcb' 'tomlplusplus')
+makedepends=('git' 'meson' 'ninja' 'cmake' 'asio' 'bitsery' 'function2' 'lib32-libxcb')
optdepends=('yabridgectl: utility for setting up and managing yabridge')
provides=('yabridge')
conflicts=('yabridge')
@@ -65,5 +65,5 @@ package() {
install yabridge-{host,group}-32.exe{,.so} "$pkgdir/usr/bin"
install -dm755 "$pkgdir/usr/lib"
- install libyabridge-{vst2,vst3}.so "$pkgdir/usr/lib"
+ install libyabridge{,-chainloader}-{vst2,vst3}.so "$pkgdir/usr/lib"
}