summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-03-17 04:59:27 -0400
committerJames An2018-03-17 04:59:27 -0400
commit90cf81ce1346e7efda58771181181564ed043dad (patch)
tree4f3f33f455d9af5b4de3cad1474273436156616f
parent868b07d402dd024b756cbda6271b7cd923a28b1f (diff)
downloadaur-90cf81ce1346e7efda58771181181564ed043dad.tar.gz
Updated to latest upstream release and targetted the source tarball.
Added composer to manage dependencies and converted package to its unpacked/unarchived format.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39d3d857b356..f585ab912e7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
pkgbase = terminus
pkgdesc = The Pantheon CLI — a standalone utility for performing operations on the Pantheon Platform https://pantheon.io
- pkgver = 0.11.2
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/pantheon-systems/terminus
arch = any
license = MIT
- checkdepends = php-behat
- checkdepends = phpunit
- makedepends = git
depends = php
- optdepends = composer
- optdepends = drush
- optdepends = git
- source = https://github.com/pantheon-systems/terminus/releases/download/0.11.2/terminus.phar
- source = https://raw.githubusercontent.com/pantheon-systems/terminus/0.11.2/LICENSE.txt
- source = https://raw.githubusercontent.com/pantheon-systems/terminus/0.11.2/utils/terminus-completion.bash
- md5sums = 3d502ca3bf6c24fc4164f8c0a17523c6
- md5sums = 727fd1133932956555ff7dbbf03f8d19
- md5sums = ee0ac20ffb763afccf64234c96575b8c
+ depends = composer
+ depends = git
+ optdepends = drush: Useful to run incompatible-with-Terminus Drush commands
+ optdepends = wp-cli: Useful to run incompatible-with-Terminus WP-CLI commands
+ source = https://github.com/pantheon-systems/terminus/archive/1.7.1.tar.gz
+ md5sums = 2752d60abe3c3e523c249ccfb2ff4a30
pkgname = terminus
diff --git a/PKGBUILD b/PKGBUILD
index 0f993f7e5ef1..6a662924c15d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
# Maintainer: James An <james@jamesan.ca>
pkgname=terminus
-pkgver=0.11.2
+pkgver=1.7.1
pkgrel=1
pkgdesc="The Pantheon CLI — a standalone utility for performing operations on the Pantheon Platform https://pantheon.io"
arch=('any')
url="https://github.com/pantheon-systems/$pkgname"
license=('MIT')
-depends=('php')
-makedepends=('git')
-checkdepends=('php-behat' 'phpunit')
-optdepends=('composer' 'drush' 'git')
-source=("https://github.com/pantheon-systems/$pkgname/releases/download/$pkgver/$pkgname.phar"
- "https://raw.githubusercontent.com/pantheon-systems/$pkgname/$pkgver/LICENSE.txt"
- "https://raw.githubusercontent.com/pantheon-systems/$pkgname/$pkgver/utils/$pkgname-completion.bash")
-md5sums=('3d502ca3bf6c24fc4164f8c0a17523c6'
- '727fd1133932956555ff7dbbf03f8d19'
- 'ee0ac20ffb763afccf64234c96575b8c')
+depends=('php' 'composer' 'git')
+optdepends=('drush: Useful to run incompatible-with-Terminus Drush commands'
+ 'wp-cli: Useful to run incompatible-with-Terminus WP-CLI commands')
+source=("https://github.com/pantheon-systems/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('2752d60abe3c3e523c249ccfb2ff4a30')
pkgver() {
curl "https://api.github.com/repos/pantheon-systems/$pkgname/releases/latest" | grep tag_name | cut -f4 -d\"
}
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ composer install --no-interaction --no-dev --prefer-dist
+}
+
check() {
- cd "$_pkgname"
+ cd "$pkgname-$pkgver"
- php -d phar.readonly=Off /usr/bin/php-box verify $_pkgname.phar
+ scripts/test.sh
}
package() {
- install -Dm755 "$pkgname.phar" "$pkgdir/usr/share/webapps/$pkgname/$pkgname.phar"
+ cd "$pkgname-$pkgver"
+
install -Dm644 LICENSE.txt "$pkgdir/usr/share/license/$pkgname/LICENSE"
- install -Dm644 "$pkgname-completion.bash" "$pkgdir/usr/share/bash-completion/completions/$pkgname"
- install --directory "$pkgdir/usr/bin"
- ln --symbolic "/usr/share/webapps/$pkgname/$pkgname.phar" "$pkgdir/usr/bin/$pkgname"
+ install -d -m755 "$pkgdir/usr/share/webapps/$pkgname"
+ cp -at "$pkgdir/usr/share/webapps/$pkgname" assets bin composer.json composer.lock config src templates vendor
+ install -d -m755 "$pkgdir/usr/bin"
+ ln --symbolic "/usr/share/webapps/$pkgname/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
}